Cant see dashboard and


My operating system is OS X 10.10.2

I have 3TB MyCloud

I cant access it through ip address. it keep saying its not possible to connect to server.

And because of that i cant set it up and use my files.

I can access my files using wd my cloud .

Even in quick view i can’t see my cloud instead of that there is “my book studio”.

I tried resetting my router(D-Link 2750u).

What can i do?

Hi there and welcome tot he WD community.

Try to do a reset on the unit bu pressing the hole shaped button on top of the ether net on the back of the drive and see if this helps you out. You can also try to see if the dashboard is accessible from a different computer on your  network.

Here is a link that might help you with he reset process:

1 Like

resetting didnt work. but i was able to access dashboard using another computer.

Any suggestion?

Try closing the browser tab that  won’t access, and open another one…  That worked for me once.  Or force refresh the page.

Interested to see what your resolution was - as I seem to have the same problem.  Also, what do you think about the Apple Airport Time Capsule instead of the MyCloud? 



Go back to the computer that you can access the Dashboard with and check the address, write it down, then go to the computer that is not showing it and use that address to see if it will open. See example image below.


Posted by,
cat0w (USA)

Yes, it seems to be a good idea to make the IP static, using your router’s control panel.

I do this for all my devices that connect to my router, leaving dynamic addresses for ‘visiting devices’.