Can't see all the files with WD2go app


I try to access my files on my My Book Live with the WD2go app for Android, but I can see only a small part of my folders and my files (maybe 10% of all the files). The first time I used the app I could see everything on my drive (videos, music…). But after having refreshed the cache the problem occurred and now it’s impossible to see all the files: always the same folders and files are displayed. I don’t have this kind of issue with WD2 Photos, or when I use on another computer: I have aces to everything on both cases.

Do you have any idea to solve issue? I didn’t try to reinstall the app, but I don’t consider this as a solution…


Hi there, I used to have that problem until I increased the size of my cache.

This is weird. Browising folders / files has no relation with the clearing cache feature or cache size. However opening large documents might have filled the cache quickly, even then when cache reaches to max, clear cache process will kick in automatically behind the seen and clears files that were least accessed but keeps 80% cache. BTW what is your cache size set to? Can you please provide more details on your usage pattern before you encountered this issue, so we can try replicating it. Thanks!


The first time I used WD2go, the cache size was set to 1 Go.

As I noticed that a file I just put in “shared music” folder on the My Book Live wasn’t displayed in WD2GO, I tried to update without success. Then I tried to clear the cache, and since this operation I see only a few folder in WD2GO. I tried to update many times in the app, or to clear the cache, or to increase the cache size, but nothing has change the result.

I notice the used cache is currently very low… 6 Mo over 10 Go available.

The currently displayed folders should make a total of data below 1 Go, even though the “Shared music” folder contains 30 Go of data.

I’ve used with success other app to access my data by using the local network or by using FTP over 3G network. In both cases I can access all the folders and files without any restriction.



This appears to be not related to your cache size setting or cache feature. I am assuming this issue happens in LAN and WAN both cases and may be related to share permission issue. By chance do you have multiple shares and/or users created  on your My Book Live. One option I would suggest is - remove your MBL device from device list screen, and generate a new DAC logging to your MBL with an admin account, and activate your device using that DAC and see if that helps. Thank you for your patience

According your proposal, I removed my device in the app and created a new logging with an admin account… It doesn’t help, I still see the same folders.

For your information, I installed WD Photos too1 week ago and this app seems to work well.