Cant' safety remove my WD Essential HDD from Windows 8.1 PC

I’m using 2TB WD Essential external hard disk and I usually go to Safety Remove Hardware when I finished using it.

However, my Windows 8.1 PC sees my external hard disk as an internal one and the hard disk name is not in the list of Safety Remove Hardware. :frowning: The PCs with Windows 7 and Windows XP is fine, because it can be set to using Safety Remove instead of Quick Removal, but I can’t do it with Windows 8.1.

Thanks for advance.


Make sure that the windows 8 PC is updated. Also, is the WD Smartware and drive utilities installed on that PC?

If yes,

Have you tried ejecting the drive from the WD smartware icon on the notification area?

1 Like

Yes, but it was install from my previous WD Passport 500GB. However, there is no name of the new WD Essential in the list in notification. So I can’t remove it with the Smartware.


I follow Cato´s solution and problem SOLVED!!

I tried EVERYTHING to solve my problem until I read his post.
I disabled System Restore and also Recycle Bin since Indexing was already disabled.
Recycle Bin: to eliminate deleted things directly instead of “moving it” to the recycle bin.

Now I can “safety remove” my 3 USB WD My Book

Thank you very much Cato :wink:

Good Luck!