Can't retrieve partition to start a safepoint

When I try to create a safepoint, I see the drive (WD Easystore 4TB), but when I click on it, it should show the partition bellow for me to select and the hit Next, but that never happens. It shows “Retrieving Partitions” but it never appears.

I have formatted the drive, deleted all volumes, reformatted to NTFS, it only has 1 volume, the drive is currently GPT, as MBR does not let me have a volume larger than 2TB.

And I have used this very drive before to do a safepoint, but because there was an error when updating safepoint, I had to format to start from scratch, and the it never worked again for this.

Did you use Windows or Mac to partition and format the drive? Did you use the operating system’s default disk management tools or did you try using a third party tool like MiniTool Partition Wizard (

Other troubleshooting steps. Eject the USB drive using the My Cloud Dashboard USB icon. Then shutdown the My Cloud via the Dashboard. Wait a few minutes then power the My Cloud back on. Wait for it to finish booting to a solid blue front LED. Then attach the USB drive and try performing a Safepoint. On the Dashboard > Settings page if USB Content Availability is enabled, try disabling it. If you have another USB drive you can test with, try using that as a Safepoint target to see if it will accept the drive when setting up the Safepoint.

I used Windows 10’s disk management tool to format and create the single simple volume. I also tried formatting with WD formatter tool, and the creating the volume with disk management.

I followed your suggestion, ejecting the drive via dashboard, shutting it down via dashboard, waiting for several minutes with Mycloud off and unplugged. Reconnected it, waited for blue light, it’s the same as before. It shows the WD easystore, but can’t retrieve partitions for me to choose and proceed.

I don’t currently have another drive big enough to create the safepoint.

Also, I noticed that when I click on the USB icon in the dashboard, it says the name of the drive correctly, but bellow:

0 KB Free of 0 KB

It’s like it’s not recognizing the volume. Although windows does it when connected to the PC.

If you eject the USB drive from the My Cloud Dashboard does the Share name for the drive still show up under the Shares tab in the Dashboard? If so try deleting the USB Share and see if that clears the issue.

The My Cloud is very picky at times with USB hard drives. Seeing the 0 KB free of 0 KB’s has cropped up from time to time for others. May want to search for those past discussions to see if there is anything suggested that may fix your issue.

As a troubleshooting step try using a USB hub (if you have one) between the USB drive and the My Cloud to see if anything changes.