Can't recognise my WD My Passport Ultra drive

Hi, I have ALL my photos stored on my WD backup drive. It was all working fine yesterday, but today it’s not even reading the drive (not showing in Explorer). I have tried a different USB cable, I have run software to try to scan and detect (Recuva), and I looked into updating the drivers (doesn’t seem to be necessary). I also tried using a different USB port and a different laptop.

The drive light is on and I can hear it’s trying to do something.

I’d greatly appreciate any help.


I have the same problem with my MY PASSPORT portable storage 3TB. I accidently pulled the WD out of the USB plug in my mac computer. When I put it back in, the mac did not recognize or even show my WD in the Finder window. I just got the WD from a firm that made data rescue, from one disk to this WD disk. It worked fine the first time I used it, but after I unplugged it, insted of push out, It wont show. Please help. I just got all my photos back. I cannot take anymore stress.