Can't Reach WDTV USB HDD from PC or other WDTV but can with Mac

I have two WDTV devices:

  1. WDTV Live named WDTVBedRm

  2. WDTV Live+ named WDTVFamRm

Each device is connect wirelessly using Wirelss N dongles listed on the approved list. My router is a BuffaloTech AirStation WZR-HP-G300NH running stock firmware. Each device can see a specific WinXP Network Share and a NAS running DLNA. Each device can play videos, pictures, etc from either the Network Share or the DLNA with almost zero trouble. It honestly works great for me (DLNA works better - sometimes have to submit workgroup name to see network shares if I’m not being patient).

I have attached a USB HDD to WDTVBedRm. It works just as expected - files play just fine and the Media Library function seems to be working and thumbnails etc are all just fine.

I can access the USB HDD on the WDTVBedRm over the network using my Mac laptop by browsing to the share, but I cannot reach it using my WinXP or Win7 computer.

I was unable to reach the USB HDD when it was attached to the WDTVFamRm using Win7 or WinXP (did not attempt with Mac at that time).

I can ping the IP address of the WDTVBedRm from my Mac. Pinging from any of the Windows PCs returns “destination host unreachable” for both WDTVBedRM or WDTVFamRm. I cannot ping either device using name resolution from either WinXP, Win7 or Mac. Dynamic or static DHCP doesn’t change the results. I did not try manually assigning IP on the device itself since all other aspects of network usage were fine.

Once I eject the USB HDD attached to the WDTVBedRm from my Mac I cannot reconnect to it unless I restart the WDTV.

Neither WDTV can see each other when sharing is enabled and a drive is connected - this was the main function I wanted to activate since I’m thinking of changing up my setup and getting either a WDTV Hub or another WDTV Live+ and using an external HDD. This was testing of that arrangement that found this oddity.

Both WDTV devices have the latest firmware.

Neither device seems to report a hostname correctly to my router when viewing active clients (but oddly a “service level” function on the router will show it - which is just odd and I’m not really sure what the difference is).

It is possible my specific router is having some trouble with these devices but that’s hard to pin down since all other aspects of networking seem to work just fine on the rest of my network - it just seems like something is messed up with the SMB sharing function on these devices.

I’ve tried many suggestions I’ve found here and elsewhere but with no solution ( other than a post mentioning a similar problem). I have not tried a “restore factory defaults” yet but wasn’t sure if that would truly help or not. I did perform multiple reboots and power resets between devices.

Sorry for the long post but it’s an odd problem and I wanted to cover many bases. Any suggestions, tips, or experience are appreciated.

I am able to see the shared USB HDD on WDTVBedRm now. It seems waiting for an hour with the device turned on finally allowed it to register correctly on the network. My PCs and the WDTVFamRm device see the USB HDD connected to the WDTVBedRm. I can browse  and ping by name and IP.

It still seems the SAMBA/CIFS could use some fixing up in the WDTV Live line … but so far it has taught me that these devices need a bit of patience.

If anybody has any hints or suggestions for making the network sharing work a little more cleanly I’d still certainly appreciate it.

I’d also like any input on how the WDTV Live and Live+ work with the WDTV Live Hub (specifically how well does the thumbnail handling work - any better than the new network shares function?)