Can't post a new message on any other board than this one?

My problem; When i run smartware.exe i get this ->

WD SmartWare System Requirements

To install and run WD SmartWare™ on Windows®, you need the following minimum requirements:

  • Windows XP Service Pack 3 (SP3), Windows XP Pro 64-bit Service Pack 2, Windows Vista®, or Windows 7
  • .NET Framework 4.0 or later
  • Internet Explorer® 7 or higher

If necessary, update your system software and browser and reinstall WD SmartWare.

 

I have XP (SP3) but not sure about the second point. I run the latest version firefox for internet access so i guess this should be ok.

 

Can anyone help here???

I am unsure how to check if i have .NET framework 4 ?

Otherwise i think my browser and system are fine.

http://www.microsoft.com/net