Can't play films with srt sub titles

I am a new user of a WD TV Live box and its great, playing everything I throw at it. EXCEPT that is movies with sub titles on an accompanying Srt file. These films play perfectly well on my laptop and PC but for some unknown reason will not pick up the non-embedded sub title file.

I thought it may be that there were several films on the memory stick so I went to the trouble of loading only a single film (avi format) and the subtitles on the stick. It only picks up the movie in its original language and not the Srt file. 

Any ideas would be appreciated 



If you’re using a DLNA media server, external subs aren’t supported. The should work fine via network shares.

Sorry I should have said that the live box is plugged directly into an HDMI socket on my TV

Doesn’t matter how you hook unto your TV. The limitation I describe still matters.

Again I apologise for mis-leading you. But, I dont stream, just plug straight into my Live Box and view films on my memory stick.


Oh, OK.   Sorry, it was me not paying attention.

Are your subtitle files named EXACTLY the same as the movie?

 What happens when you bring up the SUBTITLE selection menu in the OPTIONS screen of the WDTV when you’re playing a movie?  Does it say there are no subtitles?

Yes they are. Stupid me never read the instruction. I went into Options & found out that the subtitles are switched off by default. All is now ell and again thanks for your advice.

Thread moved to WD TV Live & Live Plus Media Players: General Discussions.



i am having a simular problem.

when played through a USB stick the movie and the srt file work fine.

however, when i try to play the movie and the srt file via network then the srt  file is not read.

having read your discussion, i am afraid to say the my server works both as DLNA and network share.

i have a WD tv live media player and a WD sharespace hard disk which acts as a server.

if i convert the srt files to another format can this solve the problem ?

any other ideas please ?

Thank you