Can't play .avi on Mac OS X from WD MyCloud - but "Can" on Nexus 4, & DLNA

I’m having this problem. I have a macbook air OS X and I got WD MyCloud for christmas.

All files like .mp4 and .mkv and .avi play on my DLNA for my Samsung TV and my Nexus 4 phone.

THE PROBLEM IS when i open up WD MyCloud on my mac, it wont open or play .avi files. Perhaps it has something to do with VLC? I downloaded the latest version of VLC. 

This is my first mac, im normally a windows guy, I know about codec, I edit videos. However, im NEW to mac.

So how do I fix the problem to be able to play all files on my Mac OS X?

P.S. - I downloaded all the files to my mac, then uploaded them to WD MyCould for storage purposes, they played just fine on my mac before I put them on WD MyCloud.


Are you able to try that with a different player?

What firmware are you running on the unit?

Please note that a new firmware was release yesterday.

Try to play them with xbmc via smb and via Upnp adding MyCloud as server.

please speak english and dont use abbreviations.


Use google, the truth is out there.

i am having trouble installing the firmware. i downloaded the sq-030301-156-20131230.deb file. no clue what to do with it. I tried to follow the instructions online and im sorry but under File, Edit, View, Window there is no “settings” to click on like it instructs. 

and no, i cant play them at all. My options are VLC or Quicktime and neither will play the .avi. if that worked i wouldnt be here, duh. 

when i switch them from .avi to .mp4 or .mkv they still wont play. all my other .mp4 and .mkv files play, just not .avi

Those are not abreviations.

XBMC is actually a media center, Google it.

SMB is network protocol (also know as Samba), but most commonly just refered to as SMB.

UPnP is another set of networking protocols and is what DLNA uses (if you don’t want others to use abbreviations you shouldn’t either).  DLNA, which is what you used in your original post (OP) = Digital Living Network Alliance.

However, mostly the reason you are having issues is due to either your MACBook Air or VLC (another abrreviation), but you need to tell exaclty how you are connecting to the My Cloud, weather you using DLNA/UPnP, SMB, NFS, FTP, etc. (yes more abbreviations…Google them).

newbphat wrote:

i am having trouble installing the firmware. i downloaded the sq-030301-156-20131230.deb file. no clue what to do with it. I tried to follow the instructions online and im sorry but under File, Edit, View, Window there is no “settings” to click on like it instructs.,487/session/L3RpbWUvMTM4OTIyMzEzNi9zaWQvaUk1VnRVSmw%3D

did you not read the title??

EVERY FILE works on DLNA and on my Nexus 4 with the mobile app.

NOT EVERY FILE plays on my macbook air. That simple

Yes, I did read the title, but just becauses the will play via DLNA on other devices doesn’t mean that is how you are attempting to play them on your AIr.

Also, as they will play on other devices, it means you have an issue with the Air, not the My Cloud.

You need to be more descriptive as to what you are doing on the Air to connect to the My Cloud and play the vids.

OK - now were getting somewhere. Remember, im stupid so speak to me on a lower level.

I use the MyCloud desktop remote app to open up MyCloud. From there, I click on the files. 

OSX prefer to connect via afp who can cause changes in names/folders in shares from mycloud use smb (also know as cifs) via finder to prevent this.

In OSX use chrome in place of safari to connect to mycloud dashboard.

OK - I have the latest firmware. 

Also - I dont use the broswer dashboard really. only for the firmware - which i set to autoupdate.

On my MBA (Macbook Air) I use the cute white and blue square app that is so convient to use on mac laptops.

All I do is click on my device (mycloud 2T) and then i have everything saved in my public folder. then I made 2 folders (TV Shows, Movies). 

Now correct me if im wrong… I get the message from VLC saying it failed to read the file. I have the latest VLC.
On Windows I would just download a mega codec pack… does Mac have that option? Wouldnt that fix the problem?

Don’t know about codecs packs on OSX.

You said previously that you were able to play the files before uploading them to your mycloud so it couldn’t be a codec problem.

How do you open files in vlc?

I assume that by stating “I use the cute white and blue square app” you mean the My Cloud Desktop app.  That’s not DLNA by the way, I believe the Desktop app uses WebDav (different protocol all together).

Don’t use that as there are issue using it to access videos (even in Windows), you need to use Finder.

This may help:

Look here:

Enable (if not yet) smb, uncheck afp to prevent names changes.

I use DLNA (On my Samsung TV)

All I do is just double click when the file is on my laptop. You know, the normal way. 
And when its in the desktop app i do the same thing. My laptop is programed to open .avi and .mkv with VLC and .mp4 with quicktime. I think thats default right?

So, ill try opening the folders and files with Finder real quick. 1 sec.

and HOLY COW! It worked. 

OK - its the Desktop App that doesnt work. 

Problem solved. the app is [Deleted - Trancer] :)

Thank you EVERYONE who helped and put up with me. Just tell everyone form now on that its the APP that causes the problems and to use Finder to open the files.