Can't open video files after firmware updated v2.21.126

So I wonder how long this will drag on before it’s fixed

Hello All,

Thanks for reporting the issue in this thread.
Please post or private message the answers to the following questions so that I can assist.

  1. What Make and Model of Mobile Device?
  2. What Operating System and version?
  3. Are you connected to the same LAN as the My Cloud? Remote WiFI or Carrier Network?
  4. What video files OTHER than what is reported are not working?
  1. android tablet / iPhone / windows 10 pc
  2. n/a
  3. everything is fine when connected to the same network. Remotely no video files play
  4. no video files play. I can download them and view jpegs but no video format files will play

I have the same issue after doing the firm ware upgrade

In addition to not being able to play videos on my tablet the upgrade has broken my internet connection

If mycloud is plugged in no devices on the network can access the internet

If I unplug it they all work :frowning:

Mine now is freezing requiring it be unplugged. Here’s what it like to show on the dashboard

Hello,

It’s possible that your Dashboard is not showing up correctly because the My Cloud is indexing your content and generating thumbnails. You should be able to access the Share using Windows File Explorer, Mac Finder and the My Cloud mobile app OK.

Can you verify?

The mobile app via iOS and android was not able to access the mycloud drive. I unplugged it again and was able to access it

@SBrown

  1. Xiaomi Redmi Note 4G LTEW / win7 PC
    http://www.gsmarena.com/xiaomi_redmi_note_4g-6561.php

  2. Android KitKat 4.4.2 / win7 Home Premium

  3. connected to the same LAN = no joy
    if i use mobile data i can open the videos but its now slower that before

  4. na

cant we just downgrade the firmware? it was absolutely perfect…

Ok, i’ve done a sys reset and the same firmware version is installed so im gonna give this firmware downgrade another go and describe it step by step:

considering this post as ref.

You can downgrade your firmware, but you need to download the firmware you want to go back to from here:

http://support.wd.com/product/download.asp?groupid=904&sid=211&lang=en535

After unzipping the file to get to your *.DEB version you have to rename that version. So lets say you are on 3.3.02.165 and you want to go back to 03.03.01.156, do the following.

Download gpl-source-wd_my_cloud-03.03.01-156.zip

Unpack the zip file to the *.DEB file.

Rename the *.DEB file to a version number that is highr than the version you are on. Example: rename 03.03.01.156 to 3.3.02.166 to replace 3.3.02.165.

Go to your Dashboard and do a manual firmware update. This will restore the older firmware.

BEWARE : that any scripts/functions that have been changed with the firmware you are on and are not addressed with the older firmware are still the current version’s script. I would do this as a last resort in trying to find a fix elsewhere on the forum.

1. download the firmare version required (WD_MyCloud_GPL_v2.21.119_20160901.tar.gz)
from: https://support.wdc.com/downloads.aspx?DL
GOT IT

2. > Unpack the zip file to the *.DEB file.
*Hmmmm… what do you mean? TO the .DEB file…? where is this file located?
maybe you mean i have to export the file in .DEB format? lets see…
- open with winzip
- cant convert, not here not online… maybe you mean to look for a .deb file inside… lets see
8 items inside - 4 folder 4 files

Folders:
firmware, kernel, opensource pack, toolchain

Files:
GPL_v2, GPL_v3, LGPL_v3, WD_MyCloud_GPL_v2.21.119_20160901… All *.txt files

- im gonna go to the obvious choice 1st, firmware folder… brb…
will save you the trouble, its not there… on the other hand what if you open text file: WD_MyCloud_GPL_v2.21.119_20160901.txt you will have instructions on HOW TO BUILD THE FILE YOU NEED

and i quote: > This file will show you how to build the WD MyCloud firmware < brillinat… at last… mystery solved…!!!

Oh wait, there is something else here:

Modification of or tampering with the Software, including but not limited to any Open Source Software, is solely at Your own risk. Western Digital is not responsible for any such modification or tampering. Western Digital will not support any product in which You have or have attempted to modify the Software supplied by Western Digital.

So, it boils down to the firmware update render my device useless, submitted a support case and bounce between WD staff via mail and Forum for over 10 days with no resolution, only links to guides that lead to “if you do it yourself your warranty is void”

Im really sorry but enough is enough… @WDStaff Members please answer the following questions:

Q1 - My device is still in warranty and has been rendered useless due to manufacturer firmware. Can you downgrade my device remotely?

Q2 - If remote downgrade is not an option, can you build the necessary *.deb file or whatever bloody file is necessary to do a manual firmware?

This has gone beyond my good will and patience, its is the 2nd time that i ask this questions and not even a bloody answer… escalating my case to yet another person is not the answer…

I am extremely disappointed with the lack of interest and/or the “difficulty” to do a bloddy downgrade.

Consider this a formal complaint and if i have to wait another 10 days for a reply that does not solve my problem just send my another device with the firmware v2.21.119.

sorry for the long post

As an FYI you don’t want the GPL version of the My Cloud firmware UNLESS you intend to compile and build your own firmware version. You can download any of the older v2.x firmware from the following post/thread:

https://community.wd.com/t/wd-my-cloud-v3-x-v4-x-and-v2-x-firmware-versions-download-links/148533

Only thing that thread doesn’t have is the downgrade instructions for v2.x version single bay/single drive My Cloud units.

Thanks Bennor, will give it another go… oh and yes, my device is a single bay… just to make things a bit easier…

Downgrade successful but i still have the same problem… great…

well at least now we know that downgrade does not fix the issue (just needed to wait 10 days and for a non WDStaff member to help me realize that)

What now @WDStaff…? Do i really have to come here every day and keep pushing for a bloody answer?

I don’t think there is a user called @WDStaff, so I’m not sure there’s any point linking it… The user who replied to you earlier is @SBrown, who is a member of WD staff. I’ve no idea if this will generate a response; maybe you have to say it three times…

i assumed that all users on the group would be notified (didn’t really want to be a pest to individual users) but you might be right… will give them another day if no one comes back will then go after individual users…

dont get me wrong, i have nothing against @WDStaff but i think i’ve been more than polite and tried all options to my knowledge and skill before coming here.

i would even prefer to keep this issues in a private chat with someone in order to get walk me through what needs to be done (couldn’t find a chat room on official WD site )… i would even settle for someone saying “we don’t have a clue why this happened and the firmware downgrade won’t fix it”… some feedback…

only email contact after submitting the case. Got this person in charge of my case and when i was not getting an answer from him i asked, not demand, to get a replacement device…

the very next day this other person came back saying that the 1st guy was not there (xmas annual leave or whatever) - well thanks for letting me know that my case is resting in someone’s desk until he comes back god-knows-when -

So ok, the guy asked me if i wanted to escalate the case, i said yes and gave him an update of the situation with a few screenshots… and guess what… never heard from him again either… if i had to guess i would say that he went on holiday too… but the point remains… NO BLOODY FEEDBACK NOR REASSURANCE,

im only getting results by coming here and being a T**at, because after 12 days im still stuck with an expensive WD paperweight and the only progress made was thanks to non-WDStaff members…

as you can imagine im fuming…

I feel your pain…

Having looked over the thread again, can I just check how you’re accessing the MyCloud to play videos/? It looks like you’re using either the WD Desktop app on the PC, or the WD Mobile app on a phone. Is that right? And these give the same error. But when accessing via your smart TV (using DLNA? Or file server access?), it works fine?

And your normal player on PC and phone, when accessing via WD app is VLC?

So, what happens if you access the MyCloud using File Explorer, and open a video file with VLC? (either open the storage device from 'My Computer", or map a network drive (which is by far the best way of accessing the MyCloud with a PC on the local network; the app is only a last-resort method for remote access, IMHO)).

In either of the apps, have you tried changing the method by which the video files are opened? I wonder if the apps have ‘forgotten’ what player to associate with video files.

Spot on @cpt_paranoia,

i know i could use file explorer to access from PC desktop (mapping the drive i think it is called), i tried that but cant get it to work (didn’t want to mess about with the drive without the proper knowledge) so i use the desktop app, i know is not ideal but gets the job done with decent speed so i left it as that.

while i was moaning about this i got an email from WD support with a fix, cant say or post it here but suffice it to say that it took me 5 sec to get the video to play again… HUUURAYYY…!

i agree with you on mapping the network, i tried and failed once and didn’t want to brake it on the 1st day. will now do some research on how to map the network.

I would like to apologize for my temperament and aggressiveness to @WDStaff . i really feel that im right but you are not responsibly for my predicament, sorry to push you guys arround to get this fixed :slight_smile:

will come back is this fix is not permanent… BEWARE… :stuck_out_tongue:

Oh, and special thanks to @Bennor, for pointing me in the right direction… twice :slight_smile:

[quote=“ANGEL_VIANA, post:24, topic:188335, full:true”]
i know i could use file explorer to access from PC desktop (mapping the drive i think it is called), i tried that but cant get it to work…[/quote]
Can you elaborate more on why it isn’t working using file explorer to map the My Cloud? What specific error is being generated by Windows when you attempt to map the My Cloud? Can you map the My Cloud using it’s IP Address (usually obtained from the network router’s administration page DHCP server client list section)?

Errrrmmmm… why not? Is it a secret?

The whole point of this forum is to share information and solutions. Like we’ve been trying to do. It seems a bit off if you can’t reciprocate…

The most common problem encountered is with Windows’ limitation on usiing mixed credentials when accessing network drives: you have to map any MyCloud shares (including Public) as network drives using the same MyCloud user credentials. It’s a shame that WD’s instructions don’t make that clear.

They have provided some troubleshooting steps but this information is CONFIDENTIAL. So we ask you not to post these steps on any forums/social media or anywhere at all. Just consider it as unique troubleshooting step for your particular issue which is very rare.

i agree with you… its unfair, and i know im not the only one with this issue but thats why im not posting it…

i agree… but considering that i could get better performance and now where and how to refer for support (sarcastic emphasis on HOW) and the information can be found online i will give it further research and another go…

Thanks for your input :wink:

I failed to see your question here :)…

i will get back to you tomorrow with a full report… thanks again for your help :wink: