Can't mount MBL shares through SMB or APF after update to OSX SIERRA

MBL shares aren’t mounting through SMB or APF after update to OSX Sierra.
Only CIFS is working now. What went wrong?


AFP is still working with the latest Mac OS. Let’s see if another user has any recommendations or insight regarding your situation.

I’m also having trouble mounting the drive through either SMB or AFP, but the MyCloud app still works, and my Kodi apps can still access the drive via NFS.

I just did a full diagnostic via the MyCloud app, and it’s reporting that there is a problem, and I should contact support. Unfortunately, the WD Support website is also giving errors. Anybody else who can point us to a direction to resolve this?

Disable client signing on the client end:

How to Fix It In One Command
Open up a terminal and enter this command.

printf “[default]\nsigning_required=no\n” | sudo tee /etc/nsmb.conf >/dev/null
Then unmount and remount any SMB shares.

Reversing The Change
If the fix is causing other issues or lack of SMB connectivity, and you need to reverse it – simply delete the /etc/nsmb.conf file with this command

sudo rm /etc/nsmb.conf
By default the file does not exist on a fresh install of OS X/macOS.

This is how I solved the SMB file sharing problem on my Mac running Sierra. Please let me know if this worked for you!