Can't map nas network drive in windows after system restore

about a week ago, the media server function stopped working. I went to twonky interface (http://ip:9000) , but no interface displayed. I have dnla turned on under settings. so I did a system restore. at first, I didn’t see any media files, but twonky interface did work. under sharing in twonky interface, I found my video files were still there under /Volume_1/Public/Shared Videos, instead of /Public/Shared Videos. once I shared those Volume_1 folders, the media sharing once again saw my files and worked. but I still can’t map NAS as network drive, in order to copy additional files, either to /Public/Shared Videos or /Volume_1/Public/Shared Videos. mounting WDMyCloudEX4 as public drive doesn’t work. I tried to WD Discovery, and it also would not let me mount network shares.  

has anyone seen something like this?   anyone have ideas on how to fix this situation?


Just for troubleshooting purposes, I recommend you try connecting the drive directly to the computer and mapping it