Can't Map MBL after latest firmware upgrade

I recently upgraded the Firmware on my 1GB MBL and ever since I cannot Map a Network Drive. When trying to map \MyBooklive\Public I receive a login prompt three times and then I get “Windows cannot access \MyBookLive\Public - You do not have permission to access \MyBookLive\Public. Contact your network administrator to request access.”

I can access the MBL via the web UI and verified that I have the correct password. However the web UI doesnt help because I have no access to any of the files.

I did not chage anything else except for the Firmware upgrade. I am using Windows 7 - Professional.

Any ideas on what I could do to fix this issue?

I’ve had the same problem as you in the past. It is not a problem with the MBL. It is a Windows registrry issue. Sorry, I can’t remember what exactly i had to change in the Windows registry, but it was something.  If you search around on the net, you will find it.

Just to make sure it is a registry issue, you should try a couple of things:

  1. set up a new share folder on the MBL and try to map to it with your PC

  2. try mapping with a MAC

  3. try mapping with another windows PC that has never been mapped before to your MBL

So I made a new share and there was no difference, still the same error. I also do not have a MAC available to try this with. I will try and get antoher machine to try out.

In the mean time, I have spent the last two days trying to find the solution for this on the internet, and so far none of the suggestions have been successful (including pokes of the registry). I feel as if I have searched the entire internet by now. Of course I haven’t but I am not sure how much more time I can waste on this.

The one concern that made me think it was the MBL was that I did a Windows Restore back to a date before I updated the MBL and that still did not fix the problem. So I am kind of lost at this point.

Any other internet keyword searches you would recommend for this? Using the exact error message seems to return a wide range of issues, of which none have solved my problem.

Thanks for the suggestion.

If it is the MBL which is the problem, then specifically it will be the SMB (samba) server. That is the program on the MBL which serves the data to Windows machines. Just like there is a http (apache) server that serves up the webpage from the MBL. 

You can test to see if the SMB server is actually running.  You can login to the MBL via Putty via SSH.  Then you can  look at this link to learn how to restart SMB

 In the event that you get an error message when restarting SMB or that it does not restart, then you need to reinstall teh firmware.  You probably will not be able to do that from teh Dashboard, so you will need to do it via SSH by tricking the MBL into thinking it has old firmware and then updating it from firmware you have downloaded…

So here is where I am at -

(1)The SMB server was restarted and still no joy.

(2) I got another laptop with VIsta on it, and it was able to map a network drive to the Public shares. So now I am confused even more. This seems to point to my Windows 7 machine.

(3) My internet searches have not turned up anything of significance.

If you any other ideas I would greatly appreciate it, otherwise I will keep searching…


Like i said in my first post to you, it is a windows registry problem.  The answer is on the net somewhere, since i know that i solved the same problem myself a few years ago. There is absolutely nothing wrong with your MBL.

Try assgining a diffferent  static IP address to your MBL in your router DHCP table.  Then trying to map from your windows machine to that new IP address.  Map it  like this /XX.XX.XX.XX/Public/      Where the XX’s are the IP address of your MBL.  Most routers give IP addresses like 192.168.1.XX, but yours might be different. 

So I tried that and it didn’t work either.

One thing I did notice is that via Device Manager, if I show hidden devices, the MBL shows up under System Devices with a hazard sign on it. The error code shown in the properties is “This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)”. I tried updating the driver manually but windows keeps saying it already has a best driver for it.

Have you tried to ‘remove’ the device in Windows Devices?

Well I FINALLY got it!!!

I am not exactly sure what I did but it was one of two things. First i got rid of the Device Manger error by uninstalling it and rescanning. Once it found it again, it re-installed without any driver issues. Next, I uninstalled the Client for Microsoft Networks for my wireless network connection. I then reinstalled the Client for Microsoft Networks. Finally I rebooted the computer and waalah!!!

Thanks for all of the the suggestions. Man what a pain for just updating FW.