Cant map drive on my laptop only

i have mycloud 4tb and i cant map drives or explore the hdd

this happend only on my laptop after a format my laptop have win7

i tried in three defirent pc with win7 win xp and everything works great

what is the problem on my laptop???


can u reach the ur NAS from ur laptop, have u tried to ping ur NAS, do u have network connectivity (home network) ?

look if i use wd mycloud software for pc i can see my files but straight from local i cant

what is ping???

i tried wd discovery no luck


if u open ur command promt, from windows home, then u type cmd in the field where it says “search prgrams an files” than opens the little black command prompt screen, than u type: ping {IP of ur NAS} = ping 192.168.x.x what IP ur NAS has.

ur try to go through the GUIDE written by jamalaya, he explains everything quite nice

i think its ok what i must do now???

When you open the networking center, what type of network do you see for your wireless network? Private or Public?

If private, this is fine.

If public, you need to change it to private

how can i do it please tell me the steps


So your network was set on Public?