Can't make advanced RMA, when submitting on payment page

An IOException was thrown while trying to execute the Http method

Please advise!

1 Like

SAME HERE

An IOException was thrown while trying to execute the Http method

WD doesn’t care. They don’t want us to be able to submit replacements. They don’t even make an announcement that their warranty replacement system is down for 2+ days now? This operation is pathetic

Same for me too.
WD, looks like RMA website is broken

Maybe WD went out of business? They have an announcements section, but don’t even announce their system is down? For 4+ days now? Got a dead drive, can’t warranty it. Same error message

Problem still exists today. April 24, 11pm EST. Please fix.

Hilarious how there was a block when clicking Advanced RMA yesterday … a pop up said Unscheduled Maintenance try back after 5PM today… Now its 10PM and still the same error message when trying to complete payment checkout for advanced RMA

Last night they blocked the Advanced RMA button. It gave a message UNSCHEDULED MAINTENANCE. Try tomorrow.

Well it is tomorrow, maintenance is finished, can get to the final checkout page & still same error message:

An IOException was thrown while trying to execute the Http method

Advanced RMA is no longer allowed.

When I go to the “Create an RMA” page I don’t even see the section “Please select the product(s) for RMA”. I called them Monday to try to manually get an advanced RMA. Was told that I would get a call back on Tuesday – it is Thursday morning, still no call.

1 Like

Think it’s fixed. Don’t wait for an announcement. WD doesn’t give them.

Don’t need an RMA, but simply typing a bogus card # used to give the EXCEPTION error message in 1 second. You can find out real quickly if their system is processing warranties or not by doing it like that.

Now it says “The credit card number is not a valid credit card”

So the system is actually processing again

I was able to do a RMA now. Waited almost a whole week of trying. WD never gave a notice. Very unprofessional, but its working again.

Your RMA has been created. An email with your RMA details will be sent within the next 24 to 72 hours. The RMA expires thirty (30) days from the creation date.

Please wait 3 to 5 hours to check your RMA status.

Contact their support service. As far as I know, guys from the support will answer any of your questions as quickly as possible. If nothing helps, maybe the problem is related to the payment getaway company that didn’t authorize the payment. You can find another company with more powerful gambling payment processors that can allow more transactions to be made. Maybe the fee will be a bit higher, but at least you are secured, and you know that no one is trying to rob you.

Huh, that seems pretty weird. I am experiencing the same issue right now. How did you fix it back then? I also thought that WD went out of business, but a friend of mine told me he ordered something from them a couple of weeks ago, and everything went fine. I also thought that it might be a certain issue with my PayPal account because I experienced such an issue back in the day. So, I decided to try another service, an alternative to PayPal, and still, nothing changed. By the way, you can find some great services similar to PayPal. You can read about them on https://www.moneyunder30.com/. Some of them are even better than PayPal.