Can't Login to after update to OS5

I just updated a MyCloudEX2Ultra from OS3 to OS5. Now I can’t log into the web portal for the device no matter how many times I hit the reset password button and go through the steps! I have had to unblock the device from bad logins. I reset the password and it doesn’t work. I get the error message “Something went wrong, please check that you have an active internet connection and try again.” There is nothing wrong with my internet connection.

I CAN login to the device admin panel, but those are different credentials than the credentials. When I go into the device admin panel, there is now a requirement to enter the MyCloud credentials to manage Cloud Access. The credentials don’t work there either and the cloud access is off. So, I really need to get my access working in order for everything else to work.

I KNEW that there would be some stupid issue with this update…

Did you create a new account when you upgraded to OS5?

I have signed into without any problems and on my Dashboard too. See example image below for my sign-in on the Dashboard.

I have a WD MY CLOUD 2nd generation. WDMyCloudImage

There is a sub-forum for your device if you want to post your topic there.

This is confusing for me to explain what I did because it was confusing for me at the time. When I upgraded it did ask to create a new account, but I wanted to use my same email for the account. I don’t think I created a new account but I just used the same email as my old email as the admin. Now, I was able to log into with that particular email address (the one I used with OS3). But then something happened and BOOM login no good - password reset tried many times with no luck. You obviously have to log into your icloud account in that spot on the admin panel to do anything with cloud access, or even make a new user.

UPDATE: I was able to log into with one of the other user’s email and password, and it of course shows the unit is offline because the Cloud Access is disabled. So, I’ve narrowed it down to that the admin user/pass account is the problem.

Oh man, this saga gets more and more interesting.

After having several failed attempts as the admin login this morning, the admin login now works. This was after I signed in as a different user to Not sure if that did the trick, but at least for now it works.
:crossed_fingers: :crossed_fingers: :crossed_fingers: :crossed_fingers:

Nope, not fixed… Now I can’t log in to mobile app or