Cant log into MyBook World Anymore with Mac OSX Lion

Tried the work a round, but It does not work for Time machine :frowning: the AFP is not compatible…

But I can now use the shares with the user login.

thank you drsam!!!

tried the work around and now i can access everything on the drive again! (GM version of Lion)

:smileyvery-happy: :smileyvery-happy:

I had the same issue this morning after upgrading to Lion…Time Machine no longer works.  Apple was good about tracking down the reason, but the solution is up to Western Digitial.  The dissapointing thing is WD seemed shocked that Lion was out…and indicated they did not know it was coming.  Oye Vey.

According to the guy I talked with at WD, they are not working on the problem and do not know when a solution will be out…if at all.

I can confirm that you cant connect to your MBW with Lion! (Even not wit the latest firmware - 01.02.06 with MioNet

The workaround drsam posted worked for me!

@drsam Thanks soooo much! Very appreciated!

(Havend tryed it for TimeMachine backups yet, but accessing all my files is fare mor importand to me!)


"A firmware update for the My Book Live, The My Book World (White Light), and WD ShareSpace is in development to update the version of Netatalk (to 2.2). At the current time, there is no work around available. "

Here’s 1 solution for this : 

sudo defaults write /Library/Preferences/ afp_disabled_uams -array-add “DHCAST128″

So i found a solution and explanation at the  Apple Developer Forum. Apple disables support for the “DHCAST128″ in OS X 10.7 LION , which is commonly used by NAS boxes. Apple thinks is it insufficiently secure. So all the Vendors must work with Apple for Lion compatibility.

To turn on “DHCAST128″ support please do the following:

1)  Launch /Applications/Utilities/Terminal and do:
sudo chmod o+w /Library/Preferences
defaults write /Library/Preferences/ afp_host_prefs_version -int 1
Now restart your computer.
2)  From Finder, select an AFP server, or use “Connect To…”.  This will cause the AFP Client to create the full preferences file
3)  Launch Terminal again and do:
sudo defaults write /Library/Preferences/ afp_disabled_uams -array “Cleartxt Passwrd” “MS2.0″ “2-Way Randnum exchange”
sudo chmod o-w /Library/Preferences
Now restart your computer.

Note:  To add a “DHCAST128″ to the disable list, use

sudo defaults write /Library/Preferences/ afp_disabled_uams -array-add “DHCAST128″



Solution by : Alexander Wilde


Have you tested this, and/or can a WD rep confirm that this is a viable workaround until the update?

this workaround doesn’t solve the timemachine issue… For information QNAP and Sinology are still providing uptodate firmwares with 10.7 compatibility…

WD is just pain…

Before people start dissing WD, please know that Netatalk  - an open source group that created a way to use AFP for free - have begun charging due to there only being 3 developers. If WD indeed use Netatalk, then we may be waiting a few more weeks then expected whilst they sort out licensing issues.

Just thought some would like to know :slight_smile:

I’m not sure about this solution really, I don’t have any other backup apart from my WD time machine one ;-(. this is what we get from rushing to upgrading to a new OS .

Where were WD guys when the new Apple OS was announced ? shouldn’t they got a developers addition to test ? like everybody else ?

I have the same problem with WD My Book World Edition II (version 01.02.06 with MioNet built on Thu Oct 21 10:19:41 CST 2010) with the official version of Lion.  I´m a photographer and all of my photos are stored into this NAS. I suppose that WD developers were working hard to solve this problem, but this problem occurs since first developers version of Lion. Is it so difficult to solve?!  I will try the workaround solution, but I really expect a new firmware version from WD to solve this problem as fast as possible!

1 Like

I have the same story, the only way is to use SMB or FTP to connect to the device.

Same story here and I use the WD for my TimeMachne back up also. How long do we think it will take for these guys to turnaround a firmware release?

One can only assume that WD doesn’t test new OS’s before public release? I can understand that Lion is a new OS to the public, but it has been in beta for quite sometime now. 

Is there a way we can get notified when the firmware has been released?

Yes, I really need someone to get this fixed as well. A) I’ve got no backup capability. B) The response by WD does not inspire confidence, and hard drives are about confidence. I almost lost access to my music collection bc of this issue. 

If the issue is that WD is relying on a third-party technology group to fix this, than shame on them for accepting that risk. If they just chose not to focus on it with a developer copy, then it speaks to where their product team holds Mac users. There are a number of other things that could be preventing the fix from coming out, but at least be transparent and sensible about it.

In the meantime, hit up the twitter account @WesternDigital and put the pressure on.

Same issue here, I mentioned @WesternDigital on twitter.  I hope they are working on a fix.  It’s a pity there’s no official response here to indicate when we might expect a patch.,335

Yeah I found that afterwards, thanks

When is the update coming out for Lion 10.7

Please notify when available

This is crazy.  I spend an hour on the phone with an Apple Care rep to find out why I couldn’t to the Internet in Lion.  It came down to reformating my drive and doing a clean install of Lion.  He said “Just run Migration Assistant to copy your data over from your Time Macine backup.”  I do the install and find out I can see my Worldbook II but cannot connect to the backup portion to restore!!!  WD need to do a firmware update A.S.A.P. !