Can't log in to get my files

I had to reset my cloud mirror… the passwords I set up don’t work for accessing my files. Can anyone help?

I just want to get my files off this thing before I smash it to bits… can’t even begin to tell you how much I hate this backwards poorly built POS!

Hey @helpmeplease2019,

As you are not able to access the files using the browser on mycloud.com website. kindly send a screenshot of the Error which you see when you sign in to the account.

For the meanwhile you may use the My Cloud Smartphone Application which is available on Play-store or App-store.

The ‘error’ is incorrect email or password on the smartphone
application and currently it won’t even connect online, but
when it did that it was the same error.

I set up the user, got the email and validated, but it doesn't

recognize the login. I had to do a hard reset to even get into it at
all - no telling what all is messed up. And having 6 different ways
and places to try and deal with it only makes it more confusing…
I should have bought a plug and play this drive is way to
complicated for me to understand.

Which reset did you do?

Any of them should reset the admin password back to default (ie removes it completely, no password). So try logging in using the user admin and no password and see if that gives you access.

https://support-en.wd.com/app/answers/detail/a_id/18643

Well that is how it was supposed to work… and did NOT.

I did 2 resets including the one that was supposed to remove all

passwords… where you hold down the reset button and plug in the
drive and keep holding the reset button for 40+ seconds… it
removed the users and reset the admin… and after added a new
user… I still can’t log in… AND it won’t send me a password
reset.

So you can access the dashboard via a web browser?

If so when you create your users again, you’ll probably need to re-register the cloud access credentials etc again and I’d also confirm that cloud access is actually enabled. Once you’ve done that check if the newly made user can be used via the apps. Maybe try creating a brand new test user (one you haven’t used previously) and see if that works.

  •  I can log in as admin but nothing else. So where ever that is
    

that I can get to the back end to set permissions etc I can get
to… but no place else.
I can’t get to the files.

Admin should have access to everything (hence the name).

To be clear, which methods of access have you tried? Just via the cloud, or also via SMB or NFS from the shares themselves via a PC? Those should certainly be available, so you can access the files from a PC on the same network as the MCM using the admin/ login credentials via SMB/CIFS from the other machine.

Anyway first things first, if you go to settings > general > cloud access , what do you see? Is the cloud service enabled or disabled? If enabled what is the status?

Then select the cloud access option from the dashboard top level menu (the one on the main screen) and click on the admin user. Again confirm the status and that there is a suitable email address for it. Do the same for any other user you have created and what to have cloud access.

  •  Well, I'm probably not going to be able to be very clear because
    

I don’t understand SMB, NFS or any of that. I’m just a dummy that
wanted a hard drive and didn’t expect to have to get a degree to
operate it. I’m using an IP address to access as admin. On
mycloud.com where I’m attempting to log in only allows an email
address to login.

  Cloud access is ON. Status connected.

  There is a suitable email address for admin (same as the user that

was set up and same password as the user)
I do see a place to get a code, but have no clue what to do with
the code.

https://www.wd.com/content/dam/wdc/website/downloadable_assets/eng/user_manual/4779-705145.pdf

See page 14 onward in the above - it’s how to set up cloud access (how you use the code). You use it in the mobile app to link the device to the MCM.

The SMB (and NFS) is now most people connect to the drive and access the files. It’s network access on the local network, from a PC or a Mac. What you’re trying to do is actually more a secondary way of accessing it (the device is designed as a network accessible storage device - that’s what NAS stands for, the MyCloud devices are NAS’s), although it’s a valid thing to do. It’s just a little unusual to be the only way you’re accessing it.

  •  Thanks but I don't have the second generation my cloud mirror -
    

it is the first… maybe that’s the problem, unless the setup is
the same.

  And I may be accessing it the wrong way but it is the ONLY way I

can. This drive doesn’t work like you would expect… unless it’s
the late 1990s. I can see it in the network folders with Windows
explorer, but when I click on it I don’t get folders or files… I
get an IP address in a browser where I can login as admin, but not
as a user… and can’t access any files.

The set-up is the same on the gen 1 as well (that’s also the one I have).

Try going through it again as detailed in that manual and see if it helps. You’ll also need to set things up at mycloud.com as well from that side of things (it’s a step in the process listed in the manual).

How you’re accessing it isn’t wrong, it’s just unusual that it’s the only way it’s being accessed. Most people access across their local network via SMB (basically Windows Network Sharing - aka CIFS), and use the cloud access as a secondary way when travelling etc. If you open Windows Explorer (not internet explorer) on your PC and enter \\mycloudmirror or \\192.168.x.x (replacing x.x with the IP address of the device) then you should see the shares that way, and have file access too (you’ll need to enter login credentials, use either the admin one or one of your user accounts).

  •  Thanks for your help, but this drive does not behave the way
    

that the manual indicates that it should. As soon as the
replacement drive arrives and I get that set up I will have to
spend time trying to figure out how to get my files off this
drive… It simply was not made for someone like me looking for
something SIMPLE… and while the ‘fix’ might be simple for
someone else I’ve spent days and days trying to figure this
out… the most frustrating thing is that this is the MOST
support I’ve gotten… (I am invisible to WD) and this is the
third or fourth time I’ve had a MAJOR issues getting this drive to
function as expected since I’ve had it. I wanted to return it
within days of getting it, but could not - where I purchased it
would not take it back.

If you have a PC you can use that’s on the same network as the MCM, I would suggest getting them off via SMB. See my post above for more details on how to do that, or if you need more details or a walkthrough let me know and I’ll see if I can give you more details (if so let me know what operating system your PC is running - Win10, Win7, Linux etc). There’s also more details in the manual about that.

*MCM? SMB?
Sorry, no idea what you are trying to tell me.

Sorry:

MCM - My Cloud Mirror (your device).
SMB - the network communication protocol used by Windows (and other machines) to talk to one another across the network.

You can get more information on SMB from the manual I linked to above. Basically you can share files and folders across a network and read them on another Windows PC / Linux PC / Mac. If you have one of those on the same network as your MCM then that’s the simplest way to read and copy the files from it onto your computer if you are looking at retiring the MCM and going for a new solution.

Does anyone have a way to contact WD and get actual support? Like
with a human being?
I’ve completely reset this thing again and it still will not
let me access my files.
It won’t work connected directly to a computer… I need to get my
files off of it!

The only route is via the support portal -

https://westerndigital.secure.force.com/ind/?lang=en_US

From there you can request a call.

Did you try accessing the files via SMB like I suggested? Not by directly connecting the MCM to the PC, but by putting them on the same network and accessing it via Windows Explorer and putting \\192.168.x.x in the address bar (you should be able to get the IP address from your router, log into its dashboard page and it should offer you a list of its client machines along with their addresses).

*Thanks for the support info.

  The ONLY way I can access is as admin through the IP address.         NOTHING

else works now . No icons in Windows explorer besides the ONE
that takes me to the IP address… doesn’t matter how many users I
set up, the login on mycloud.com gives me an ‘invalid
user/password’ error.

  After messing with settings I was able to get an icon in Windows

Explorer that actually showed me a folder… NO CLUE where is
folder is (it is NOT one of the shares) or why it was the only one
I could access… it had 2 useless files… no idea why I was
allowed to access one folder. But it’s gone now anyway.

  Client machines?  I think I know what you mean, but how does that

help be get my files off this drive?

Client machines - the machines that the router is giving IP addresses to. But from what you say you already know the IP address of the MCM?

When you open Windows Explorer (not the desktop, nor Internet Explorer) and type \<IP address> (obviously replacing IP address with the IP address of the MCM) you should see a screen with all of the shares on your device. Below is what mine looks like (with some information redacted) on \\192.168.0.201 (the IP address of my MCM on my network):

If you then double-click on the share folder, it should open up showing all the files and folders inside it. You can then drag/drop them off your MCM and onto your PC.