Can't locate my WD My Book 1130 in my Windows Vista

For 2 weeks now I have not been able to locate my WD My Book 1130.  My USB drives seem to be buggy, I have a lot of devices in and out, and general problems with rebooting my Vista.  However, all of my other drives and USB devices seem to be readable, except the MYBOOK 1130.

Do I need to download the firmware online?  Any help on getting my Vista to read this drive again would be greatly appreciated.



Hey, you can try different cable, different computers, also you can verify in a windows seven computer, also if you are using a hub, this may lead to not be able to read the drive, and always connect the unit directly to the power line

Thread moved to WD External Drives: My Book for PC.


I tried a different computer and it gave me the option to “format” it.  (Not sure if format was the term, but the process before you can start using the drive).  I got scared to try because I fear I might delete the data on it.

I doubt its the cable, but I did at one point have it hooked up to a hub.  But the cpu still can’t read it, whether its in the hub or directly in the computer.

Any other ideas or ways of tricking the system into reading my External!


Does the drive show in Disk Management? If so maybe TestDisk will repair the partition data. Also try connecting to a back port on the PC sometimes this makes a difference.


I haven’t had much time to work on this problem…but NO I cannot see the drive in Disk Management!

It doesn’t seem to recognize the hard drive at all?

What else can I try?

The only thing left I can think of to try is to disconnect drive shut down PC then unplug for about 10 min. Sometimes this clears problems the BIOS. Reboot and reconnect drive.


I just tried to unplug for 10min+ and rebooted.  Still doesn’t recognize it!

I downloaded some software on WD’s website, but it said in order to run the firmware I had to wipe my hard drive clean!  (Which I obviously did not want to try).

Any other options? 

Just as an aside,

When I plug this device into my LAPTOP (seperate computer), it immediately prompts a “Driver Software Installation” Screen.

It says Ready to Use the Storage Device, and Ready To Use the WD My Book 1130 USB Device, and searches for a Windows update for the “WD SES Device USB Device”.

Why is this able to work so quickly on my laptop and not even make a peep on my Original CPU Desktop?

Other external drives work fine on my Desktop, no matter which USB port I put them into.  Yet the WD My Book 1130 won’t even budge the Desktop?

Might have putting this device in a seperate USB hub have totally messed things up?

What OS are you using on PC with the problem? I’ve got a Dell XP that is real cranky about moving USB devices to different ports. Did you look around the device manager with the drive connected? If you can find it there delete the driver disconnect and reboot PC and reconnect drive.


I have a Gateway FX6000 running Windows Vista.

It is also really crank about moving USB devices, but ALL my other ones (external HDs, Printer Usb, ipod etc…) eventually tend to work.  The MyBook 1130 on the other hand seems to not work at all!

I deleted the WD SES Device drivers (there were 3)  then it refound it and installed a new one and it now says

Ready To Use – WD SES Device 



After restarting it took me several attempts just to get into Vista (for whatever reason)?  Once I got in, I plugged the drive in, and it still is not being recognized or even acknowledged (with a sound or indicator of acknowledgement in the drive).

Not sure what to do anymore…running out of options.  Do I have no choice but to reformat the drive using the newest firmware?  Will that even alleviate the problem, or just wipe my hard drive clean (if it isn’t already)?