Can't keep MyCloud 6TB connected

I lost connection to this device. When I pull the power and let it reboot, it’s visible for a few hours. When I leave it alone, it’s back to missing.
I can’t access it from Windows,, the app or the IP address.

I did a pin reset (40 sec). It rebooted and ran fantastic last night.

Now, it’s out again.
The light is blue, and everything is spinning fine.
I use the FING app to see the status and see that it is connected to the assigned port and active on WiFi. I can SEE it in Windows, but I can’t access it. Nothing else works.
It’s maybe 3 years old.

Any ideas?

UPDATE: Upon checking the router, I don’t see the assigned .18 spot I assigned it being used. I registered it as a static IP. It showed reserved yesterday, but nothing now.

I’m about 99.99999% sure that it has nothing to do with the My Cloud and 99.999999% sure it has to do with your router, network, other devices, IP reassignment and so on.

A couple of things to note, remember to assign the static IP outside the DHCP assignment range. I.e. on your router you can set the range that the DHCP assigns the ip from to You can then set you static ip from and upwards. Keep it below just to be safe as I think is the subset broadcast address.

Reset your modem/router from time to time, like every month. Mine seems to act up with devices not responding as they should, like my most recent problem of having my iHome Smart Outlets dropping off the network and as I was ready to replace my whole network of smart plugs and post up a nasty review of iHome, I discovered that all I needed to do was reset my router and all my ihome Smart Plugs worked as they should.

Network problems, like Ring which defies video viewing even though my router is 10 feet away. Although it wasn’t a router reset that fixed it, it was a total network re-arrangement that finally brought back Ring Doorbell video viewing. I didn’t believe that it was my network, but it was. I was ready to buy another Ring Doorbell thinking mine was broken.

Throughout this forum I had posted up various solutions to the my cloud dropping off the network like check your date and time, get a switch and use that to buffer your whole home network from the modem/router, to problem resolute, pull everything off the network leaving only your modem/router connected to your My Cloud and see how well it survives, connect it directly to your PC just using a straight thru ethernet (no need for a crossover ethernet cable).

It is your network/modem/router/IP clashing, other devices etc…

It is not your My Cloud.

However if you prove me wrong, I will go away forever and never try to tout that it isn’t your My Cloud but your network solution again.

Good luck…

Well…I like all of that!
I’ll mess with it and report back.
I can’t seem to get back into the MyCloud to change the settings…so…I guess a reset again.
I reset the whole network and kept having the same issues. The modem is newer than the cloud, so I assume it’s not dying.
I didn’t know I could assign static IP past the range. Interesting.

It seems all other devices that try to use the network are working. Netflix is fine. My Laptop is fine.
The settings though…
Maybe I’ll remove static IP for a bit and see if that fixes anything first.

That is the reason that the My Cloud has been blamed which is the same reason that I was going to write a scathing review of the iHome Smartplugs, Ring Doorbell and anything that falls off the network.

The difference between a working network with your laptop is that your laptop can re-acquire a working ip when it needs, where-as devices like your My Cloud that falls off your network is really an end point device and just sits there not realizing that they have fallen off the network; basically the IP has expired for some reason. i.e. the phone doesn’t ring because the phone service has been cut off. Meanwhile you who are trying to phone your My Cloud and it doesn’t answer is swearing at the My Cloud for not picking up.

you have to, otherwise the router re-assigns the IP or deactivates it depending on the router. The my Cloud device thinks that it has a valid IP and doesn’t renew it, which is the effect of when you reboot, the IP is assigned by the router to the My Cloud and since the My Cloud doesn’t renewed at the end of the time limit (i.e. time to renew set for half hour), it falls off the network and requires a reboot.

Incidentally, you should be able to just pull the network cable off and plug it back in rather than having to reboot the device. Theoretically anyways.

Still fighting. I unplugged the cable and can now access the actual IP address now. Nothing else. It defaulted to dhcp somehow.
My status now just shows as “internet access.” Seems like it should say “connected” or something.

It looks like my users got reset. Likely when I reset the box. That’s why the other stuff is messed up. Gotta make new ones.

I pulled the power on everything.
I pulled the ethernet.
All back on. Accessed the ISP link. Didn’t change to static. Added my user again. Found it in the app and
Came back to it 30 minutes later and can’t access anything again.

The mystery continues…
Hours later. New cable. Several resets. Blue light. Nothing visible anywhere.

Although much have changed with the My Clouds like moving to Busy Box which allows you to pull the power plug on the My Cloud, I still don’t recommend it. Thus if you are able to just unplug the ethernet cable and replug it back in and able to see the My Cloud afterwards, this is the best way to re-fresh the IP if possible.

The problem with pulling the plug on a MyCloud is that if it detects that it needs to do an FSCK which is a check disk which takes a bit longer to boot up, there comes a time when FSCK doesn’t complete and may leave your MyCloud in the red. So be careful with yanking out the power cord willy nilly.

how are you accessing anything and what is anything? If you are using the MyCloud program of some sorts, I don’t have that experience and it could be the MyCloud app program at fault for all these years.

For the last decade on all of the WD NAS devices, I have always mapped the Mycloud to my Mac by specifying the device name of which the default name is wdmycloud.local

A mapped drive stays mapped even on my MacBook when it is sleeping. It will stay mapped as a drive for hours, days, weeks. Thus when I want to access the MyCloud, I double click on the mapped drive icon and the MyCloud wakes up. On a PC, it would be a drive letter. I usually map it to the letter Z.

If you know the ip, specifying the exact IP is even better because you don’t have to rely on DNS to resolve the name. A DNS server is running on your MyCloud to resolve the name to an ip thus if for some reason you are on a different network which can happen if you connect two routers together causing your myCloud to be on a different network, DNS would not resolve the name and thus you have to specify the exact ip address.

I’ve found that if you attempt to browse for the device it works with varying degree of success; sometimes you can see your device, sometimes you can’t, but specifying the name or ip always works.

Mapping a drive to your PC or Mac has worked for most of us hard core users for the last decade. I haven’t had a My Cloud dropped off the network when a drive is mapped; except for the time I had different DNS address on my MyCloud and my router. If you do have different DNS addresses because you read on the internet that Google DNS is faster or that other new DNS is the fastest by setting your PC to DNS (google this) then sometimes resolving local names may be a problem. Although you may not have done this and probably skipped reading this, the DNS within your network must be reachable, i.e. your MyCloud should point to your router at as its DNS.

Any other method of attempting to access the mycloud, I have no idea. Also accessing the Dashboard via http://wdmycloud.local/ or is another method of accessing the mycloud.

As long as either mapping or accessing the Dashboard is accessible, then you are good to go.

I did another 40 second reset yesterday. Still working on default settings.
We’re getting there…
I’m going to put your comments into action. We’ll see.

The 40 second reset is on the script when you contact WD. If that doesn’t work they will trade you for another refurbish drive (just another drive that a user has sent in). Just like Microsoft in the old days having you do the CTRL-Alt-Delete.

Just make sure you turn off all media settings. Turn them all off, including your My Cloud access from outside your network and one more thing, make sure you DON’t have any USB drive attached (yes an attached USB drive will take down a My Cloud when rebooting (this was in the past, don’t know if it does now.). Turning off all media just makes sure that your drive isn’t being scanned every time it gets reset. You can turn them back on later when you discover how to make your My Cloud work.

No more 40 second resets… it is as useless as changing the oil when your car won’t start. Although if you just updated your firmware you can do the 40 second reset but otherwise no.

no we, just you :stuck_out_tongue: although when you get there, let me know and I’ll be happy for you.

For 4 months, this thing has been a champ.
Now it’s back to being difficult… Then no connection. It stopped mid video stream.
After every option, I did another full reset. It’s been loading with a pinkish light for like 12hrs. I’m open to suggestions again. Is there a way to bypass this insane load time? Are all NAS like this?

Can’t login via IP or Not currently visible on windows.