Can't install Windows 7 on WD1500HLFS-01G6U4 VelociRaptor

Thanks for any help in advanced. I’ve searched the WD, EVGA, and Windows forums along with the standard Google searches and haven’t been able to figure out my problem.

I recently had my older 150GB Raptor drive fail and RMA’d it and got the WD1500HLFS as a replacement. I installed it into my computer, disconnected my other two 1TB WD Caviar Black drives, and attempted to reinstall Windows 7 64-bit onto the new VelociRaptor drive. The Windows 7 installation doesn’t recognize the new drive though. I tried different SATA ports on my motherboard (which is an EVGA 780i SLI 132-CK-NF78 motherboard running the latest P10 BIOS). I also reconnected my two 1TB drives and the Windows 7 installation detects those without an issue. I also tried loading the SATA IDE drivers I downloaded from EVGA’s website during the install, but it still won’t detect the new 150GB drive.

After that, I ran the DLGDIAG 5.04f on the drive (quick and extended tests) and it found no issues with the drive. I booted up Windows on a separate 500GB hard drive I had with the new VelociRaptor drive connected and it showed the drive without an issue. I also tried formatting the new drive within Windows, but the WIndows 7 installation still won’t detect the new hard drive.

The drive is standalone (no RAID), and I never had this issue before with the older 150GB Raptor drive (reinstalled Windows several times with the old drive). So needless to say, I’m at a loss. Has anyone else ran into this issue or have any further suggestions?



Mate, how about contacting WD support directly. This seems odd.

when you say you tried formatting the drive within windows, were you able to format it?  and once formatted, win 7 still did not detect it?

Yes, the drive showed up in Windows and I was able to format it without an issue. After I formatted the drive, the Windows 7 installation still did not recognize the new hard drive.

you may need to check with your motherboard company and see if there is a compatibility list for hard drives.  It’s possible that the drive is not compatible with the board.  If that’s the case then you need to contact wd and get the drive changed, or buy a compatible sata card.

Well I know that the problem isn’t with a motherboard compatibility. The drive shows up just fine in the BIOS and slaved off of a different drive that alread has Windows 7 installed (as I already stated).

I can also install Ubuntu onto the same WD1500HLFS drive in this computer with no problem. I also know the issue isn’t with my Windows 7 disc as I can install it onto a different hard drive in this computer without an issue.

The problem is only with installing Windows 7 onto this WD1500HLFS drive. Any other ideas?

Ok, I seem to have found a workaround for the issue. I tried to install Windows XP onto the drive and it found the drive, formatted it, and started installing with no problem. I broke the XP install and tried it with my Windows 7 disc and this time it found the drive with the partition that was created by Windows XP.

This is enormously frustrating. I’m not sure why I had to format the drive from the Windows XP install to get it to work (formatting in a slaved Windows 7 computer didn’t…).

Anyways, thanks for your help.