Can't initialize a 3To WD RED Hard Disk


I bought two 3To Hard Disk (NASware 3.0 WD30EFRX) for my NAS (QNAP TS-253a compatibility ok).
When I put the two in my NAS it said me to format the drives before using them.
Ok, so first I tried to connect the drive to my laptop with an SATA 3.5" to USB adapter (UGreen), then tried to initialize with the Windows 10 disk manager. It detects my hard drive and tells to initialize the disk but it fails saying “Incorrect function”. I got the same error with the other HDD and on my desktop computer and also tried with diskpart I did a “clean” then a “convert mbr/convert gpt” but fails with the “Incorrect function error”.

Here, the error from Windows Event Viewer : VDS fails to write boot code on a disk during clean operation Error code : 80070001@02070008

I also try to put an operational (formated) HDD in my NAS alongside one WD RED but the NAS only recognize the first one …

Gparted doesn’t see the WD RED HDD …

Wham I am doing wrong ? Are the disks dead (They are new :cry:!!) ?



Please try testing the units using the WD Dlg tool. If the units are showing any issues, contact WD support for assistance.

Thank you for your answer. I tried so many thinks I have forgotten to mention that, I ran this tool it passed “Quick Test” and “Extended Test” instantly and failed “Write Zeros” with a Test Error Code: 20- Delete Partitions error!

I am contacting WD support.