Can't get WD Elements (3TB) working as an internal drive

Hi, I have a 3TB WD Elements USB drive and now want to repurpose the HD as an internal drive in my HP microserver. This worked fine with other drives I tried, but it turns out the WD has hardware encryption which means that though it mounts fine via USB I can’t get it to mount via SATA.

If I get all the data off the drive and then reformat it, will that make it behave like a normal drive, or does would it always need to be connected to the external board to work?



As far as I know Elements is a simple plug and play drive without encryption. The drives that come with Smartware are hardware encrypted.


Ah OK, you may well be right - I had jumped to the conclusion as I couldn’t get this drive to mount and saw other people with WD drives reporting that the hardware encyrption gets in the way. 

That said, this Elements page on the WD site does mention Smartware:


Could it be an issue with the server not being supported a supported OS.