Can't format WD Elements Desktop 2TB


This is my first post here. I’m trying to format this external HD to ntfs using Linux. Everything seems to be OK but the process hangs on “Syncing device.” message. I tried with the command line>

sudo mkntfs -c 512 -v --debug -Q -I -F -L WD1 /dev/sdb1

The same happens when I try to do it with GParted, the process hangs in the same point.

Does it mean the disk is damaged?

Thank you very much in advance,

Luis Pablo

If you look in the drive Specs Linux is not a supported OS. It’s hit or miss whether they work on it. If you have access to a Windows PC try formatting it there.


Thank you for your reply. I tried with a Macbook with “WD Quick Drive Format” utility and process stops with this message:

“Cannot open device. Is WDDM running?”

Am I missing something? How can I fix it?

Thank you in advance,

Luis Pablo

Just partition the drive on the Mac

Go to disk utility and create one partition

make sure to back any important files prior to formatting

Thank you for suggestion. I tried but it also failed during format process. Disk Utility ended with this error message:


Partition failed with the error:

File system formatter failed."

However partition table seems to be created. Then I tried to format the disk using “WD Quick Drive Format” utility but I get the same error than before: “Cannot open device. Is WDDM running?”

Any idea will be really appreciated. Thank you in advance,

Luid Pablo