Can't format my 2TB WD20EZAZ hard drive due to write protect

hey guys!

drive suddenly write protected after a 1 sec power fluctuation, which makes my hard drive hardly to read and can’t format it because of too many bad sectors, tried low level format from WD Diagnostic tool but no luck, please help me, will return it for warranty but before that i need to format it.

thank you guys

Probably best bet is to use WD Lifeguard and fully erase the disk before reformatting it

I already used that software but no luck, can’t format it due to many bad sectors

If the disk is that bad, then it’s time to get a new one.

yes it’s bad but before returning it for warranty, i would like to clean wipe my hard drive first

that is why I suggested WD Lifeguard which can erase the disk

try the quick erase and if that succeeds

are you even reading the post? I already stated it that I tried WD Diagnostics(Lifeguard) quick erase and low level format

try the FORMAT /R on it and see how it manages

the /R will attempt to recover bad blocks

it may take some time to handle a lot of errors

already did that at first, diskpart also, but stuck on write protection error

Given the disk problems RMA it as is. WD is not concerned with personal data at all.

yeah i doubt they are concerned about personal data, but the local store that i’m worried about

contact WD directly