Can't format, can't see my 'whole' external drive

Almost a year ago I succesfully installed and partitioned my external HD, but I haven’t used it for a while. 

Today I connected the HD to my computer and it showed up in the directory as a separate drive (F).  I was fiddling with some of the files that came with the HD and I must have clicked on a program (.exe file) that suddenly–whatever the expression–‘moved’ the HD directory to my DVD RW drive. 

Now when I go to the DVD RW drive, right-click on it and then go to “Properties” and then to “Hardware”, one of the disk drives listed is “WD My Book 1110  USB Device”.  I’ve removed it, but it pops back in. 

Using  Disc Management, I managed to make my partitioned HD visible, but I still cannot see the ‘whole’ drive (as I was able to see before), which contained all the files that came with the HD.  I don’t care about the data on the HD and I want to format it.  I also downloaded a formating software from the WD webpage, unzipped it, but I get a lot of error messages when I want to run it.  I’m getting some error messages pertaining to the WD files stored in the Program Files directory on my hard drive C.

I believe the source of the problem lies with what I initially done, ‘shifting’ the HD to the DVD RW drive.

I’ve tried different things, I’ve tried to find out the answer, but to no avail.  I’d really appreciate any advice I can get and solve this problem

By the way I am running Windows 7.



WOw, you better try to contact tech support just to see if they can help you with this.