Cant format 3tb Sata3 in Sata2 port past 764mb

Hey guys

I have two pcs. One running WHSv1 and one running Windows 8.

WHS (32bit) - sees 3tb in Bios but the O/S won’t format past 764gb (note: thats NOT the 32bit limit which is 2.1gb(?))

Windows 8 (64bit)- SSD (working fine), 3tb in SATA 3 slot (working fine) BUT, if i put ANOTHER 3tb in a SATA 2 slot, it won’t see passed the 764gb limit either!? (Again, BIOS see’s it as 3tb)

In BOTH systems I can convert it to GPT and it makes no difference, still get stuck at 764.

So, this seems to suggest that my Western Digital Caviar GREENs cannot be used in SATA 2 slots as the evidence says it’s nothing to do with 32/64bit (as it works in SATA 3 slot) or the O/S (same error on both)… is this correct?

Any ideas why I might be seeing this strange limit and how to get around it???

Do you have UEFI enabled in your bios?

Hey Tinwarble,

thanks for the reply! :robothappy:

I’m afraid both PC systems have the older, traditional BIOS and don’t appear to have an UEFI option in them.

You might also want to take a look at this:

Hmmm… just reinforces my view that I should be able to at least see 2.1gb worth of data in the OS (don’t forget, BOTH BIOS’ recognise 3TB fine (and one is actually already using a 3tb disk correctly)).

At very least I would have expected Windows SERVER to allow me to have 2.1gb and .8gb partitions on the disk… and it doesn’t explain why the 64bit, Win 8 box (already using an identical WD 3TB disk with 1 partition), will not see more than the same 764gb limit.

The only difference is either a SATA 2 or SATA 3 connector (with SATA 3 allowing the O/S to see 3tb)… so why would SATA 2 recognise in BIOS but not O/S?

… maybe I need to check the SATA 2 chipset drivers and go straight to the chip makers websites?

As the article states:

Fortunately, you can find drivers and utilities that allow you to use a 3TB drive as auxiliary storage with any flavor of Windows, XP or later. I say “auxiliary” because you can boot Windows from a 3TB drive only if it’s 64-bit Vista or 64-bit Windows 7–and then, only if you have a PC with an EFI/UEFI BIOS. EFI is Intel’s Extensible Firmware Interface, and UEFI (United EFI) is the nonproprietary version based on the 1.10 EFI spec.

If you don’t have the correct drivers for it to see the drive, then even if the bios sees it as a 3TB drive, the OS will not.  And the reason that you have different results on SATA2 & SATA3 is most likely because they require different drivers.  For  example, I’m building a system right now and the mobo that I’m using requires seperate drivers for the SATA2 & SATA3 as well as USB 2.0 & USB 3.0.