Can't find shared folders

Having no luck getting the unit to see a shared folder on my desktop. Have wired connection with network that sees my desktop. Newbie on much of the networking items. PC with Win 7. It’s asking for a user name and password, and it appears it’s trying to access the name of my network as defined by a Linksys E3000 router, not my PC. I’ve entered the user name and password for both the router and Windows log in and neither work. I’ve read on the board the unit won’t connect with Homegroups, only workgroups but I don’t know how to change to one or the other. I’ve set up sharing for one music folder. Any help? Greatly appreciated!

Hello Mebobo, see if the following KB article helps. 

How to share a folder in Windows that can be viewed with the WD TV Live, Live Streaming, Live Hub, or Live Plus 

If the problem continues you can try disabling password protected sharing. Go to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings and turn off password protected sharing. 

Thanks for your response. Password protected sharing was turned off and it still asks for a username and password. I still think this might be a router problem, not one with Windows.

Can you take screenshots of what you’re seeing / doing and post them?


See the first post in this thread below to be sure you have set up Network shares on the media player correctly.  I suggest you not use any passwords at first (or later, at all) to keep life with the device simple.  If you really want passwords, you can follow the instructions here, later.  How to resolve Network shares access problems 

Homegroups can be shut off via the Control Panel of Win 7.  Be sure the workgroup of your PC matches that of the media player (i.e. WORKGROUP).

If you have never set up sharing on your PC until now, and you have another PC, try to share some files/folders between them at first, and keep the WD player out of the picture until you have success this way.

Thanks for the response. If I don’t disable the Homegroup setting completely, will I not be able to connect with the WD unit? If I leave Photos and Printers selected in Homegroup, is that ok? I can not disable the login username and password function when trying to access the one music folder I want to use the WD unit for. That is where I get hungup.

The PC and WD unit both show “workgroup”. Hope that makes sense.

The way I understand things is you don’t need Homegroups at all if you have a traditional workgroup set up.  I can share anything like photos, music and even printers without ever using Homegroups.  I have never used Homegroups.  Go into Windows advanced sharing via Control Panel and set all that stuff up.  Turn off Homegroups.

One thing worth noting is that you have two sets of permissions to deal with here.

1) Share permissions - user access permissions that only effects users coming from a remote machine 

2) File System Permissions - user access to the files and folders on the local machine that effect both local and remote users.

You need both of these set correctly to access media on your windows computer from your WD SMP

Good Luck