Cant find nas on second router


I had my nas connected to my first router (..1.1) static ip ..1.50 and everything worked fine even on second router (..0.1). But now I had to move the nas, so its connected to the second router with a static ..0.50, but now I can find it on devices connect to the first router!?
Does anyone have an idea what the problem might be?


@lucyher What troubleshooting steps have you taken so far, if any? Have you rebooted everything on your network?


Using different IP subnets for network clients often leads to the problems you are experiencing. Normally when using two routers with one connected to the other; one would disable the firewall and DHCP server on the second router so all devices connected to both routers obtain IP addresses from the same subnet (example: 192.168.1.x).

Some routers can be configured for AP (access point) mode which typically disables the firewall and DHCP server.


Yea i fixed it by disabling dhcp on the second router. Thanks for help.