Can't find my files..."this folder is empty message"

My passport was working fine yesterday until i tried to access it this morning. The USB is connected to my desktop and is associated to my F: drive. When examining the properties it indicates in have 296 GB left and only 2GB used. When running a scan on it, i see all my folders and files in there. I decided to try to copy the entire F drive to my local desktop…took about 5 mins to copy 2000 files over to validate something is there. However trying to access the copy folder on the desktop gave me the same error “this folder is empty” - how is it that it’s empy when it was just transferring the files?

Can someone please help me? I need to access these documents…PLEASE.

try to use another computer to access the files from your drive…

try to check the cable connecting the ext drive to your computer, snuggle fit the cable

there is also the possibility that your computer or ext drive is infected with a virus or your ext drive is corrupted


I am researching again to see if there is an answer to my problem. I started last year and found none. 

How can the external hard drive become corrupted? Can you explain please. 

From what I can understand, I turned on my computer with mypassport connected and the computer began indexing the files. After hours of doing this, I stopped the process. 

The external hard drive does not register on the device manager, nor the disk management. When I connect it to any computer, it doesn’t come up. 

I tried to access the files via the program files for Western Digital and tried to reinstall. Says corrupt. 

20,000+ photos/videos were stored on the external hard drive. I have not read any post with this problem and I did send an inquiry. 

Thank you for your assistance.