Can't enable ssh access by key

Dear WD Community
I’m new to your products (this is work related) so please be kind in case the answer to my question seems obvious to you. I found some similar threads but they didn’t solve my problem.

My system:
WD Firmware 2.21.119
BusyBox v1.20.2

I use an ssh connection to store some backup files. I already dealt with the old openssh version (5) and the deprecated dsa keys. So I got access through ssh by entering the password. For several reasons I would rather prefer entering via ssh key. I did all the usual ssh stuff (creating key, adding to authorized_keys, set permissions, etc.) but then my problems started.

  • First of all I was wondering why the ssh files are stored at /etc/ssh/ and not in /root/.ssh/.

  • Second, I couldn’t restart ssh by “sudo /etc/init.d/ssh restart” or “sudo service ssh restart”, both resulting in “command not found”. So I tried rebooting…

  • Third, everything I changed in that location gets reseted as soon as I reboot, probably also on other triggers. I also tried to set up everything in /root/.ssh but the same problem, actually the root directory gets emptied entirely every time. I guess this is intended.

So, I am kind of stuck at this point not knowing how to do this ssh configs which are done smoothly on other linux systems.

Thanks in advance for any kind of help, I really appreciate it!

Hello,

I have not experienced your situation. However, the WD Community was created for Users, such as yourself, to help one another, and to share your experiences and ideas with one another
Let’s see if another user has had this issue and can share some experience with us.