Cant downgrade my firmware.. Help

Ive got the latest firmware for my wdtv live… i  want to downgrade to see if an earlier version will work better.

I downloaderd the earlier firmware Firmware Ver. 1.04.10_V unzipped and put the 3 files onto the root of my usb thumb drive however, the wdtv life isnt detecting the thumb drive with the earlier firmware… I formatted the thumb to MS DOS FAT.   

Any thiughts as to why this isnt working?

You should edit the xxx.ver file after copying it to USB (e.g. with Notepad), to a higher version number than your current one

Or, just use the rollback packages.

i did use the rollback packages… downloaded it fine… put it on my thumb drive but the thumb drive isnt being recognized by the wdtv live… tried it with another drive as well… same result.

I suppose you mean FAT32, right?

correct… sorry my bad

You may try another thumbdrive (another brand if possible). Just use it as it is formatted from factory

Eyeonthedesign:   Is it not recognizing the DRIVE, or not recognizing the FIRMWARE?

If it’s not recognizing the drive, the EJECT button won’t do anything.  But if it is, then EJECT will list your drive.

If it DOES recognize your drive, then chances are you have the wrong rollback package installed on the drive.