Can't detect network drive. CAN play media using Twonky

Hi all,

I’ve spent several hours searching messages here trying to figure out a conneciton problem with a My Book Live and am hoping someone can help as I can’t figure out what’s wrong.

My music and video files are accessible and streamable via Twonky just fine if I access the files via 192.168.x.y:9000.

However, I want to be able to easily tranfer files to and from my MBL as I *have* done in the past. Currently my Windows 7 PC does not detect MBL as a network drive, so I can’t map a drive letter to it. 

The specifics:

  • can’t access via \mybooklive. Windows says not found.
  • can’t access via http:// (again, not found)
  • can’t connect via ssh, telnet, ftp, or sftp using default ports. Connection refused.
  • can’t access via direct ethernet connection. Device not found.

Tried:

  • rebooting pc, mybooklive, router, and Twonky several times

  • resetting and powering down/up router

  • resetting and powering down/up mybooklive (held reset 4+ seconds)

  • using different ethernet cables and router ports

  • disabing firewall (Kaspersky). windows firewall already disabled

  • running “new view” to find the device, but only my pc is listed

  • using WD Link to find the drive. Nothing appears in the UI, but I also do not get any error messages.

  • using WD smartware. No external drives detected.

  • connecting pc to router via wireless connection and via local connection (neither had any effect)

  • accessing the UI web page in Chrome, IE, and FF 

  • accessing the UI web page repeatedly during MBL boot and after boot (device never found)

  • upgrading router firmware (DIR-825) but router won’t accept the files

network discovery is turned on.
upnp in router is enabled.

windows pc is in a workgroup called WORKGROUP which I read is the default group for the MBL

LED light on front of MBL is blue at boot, then solid yellow, then green (either solid or blinking).

Again, I can access my videos and music just fine if I access the files via 192.168.x.y:9000.  Or I can double-click the twonky icon in the “Devices” list and browse media using Windows media player.  But I want to access the files (including non-media files) directly as a network drive as I have done in the past.

The last time I remember everything working normally was a few months ago. I had the drive detached in the meantime, and it was always handled gently.

Help, anyone? Please?  /cry

I had a similar problem once

the problem was that I did not have Client for Microsoft Networks installed

after that it worked fine

have you tried multiple computers?

1 Like

Yep, tried those too.  There are probably several other things I tried but just forgot to put in my “already tried these things” list.  lol

I am giving up on this after spending many hours on it.  Fortunately a lot of the files that were on my MBL I also have on a 3tb drive from a different company, so I’ll go back to using that one even though it’s not a network accessible device.  I am stillable to access files via the Twonky browser, so it’s a matter of retrieving them and saving to a different disk.  There are non-media files that I can’t access, but at least I can get to most of my stuff.

I’ve bought 4 external drives over the years.  3 were WD and one was from another company.  2 of the WD drives no longer work correctly, and one of those 2 doesn’t work at all.  /sigh  As someone else said, the devices are great… when they work.

Thanks for your help, though.  It’s people like you who give the rest of us a glimmer of hope, even if it’s temporary.

Thanks for the compliment… Brought me to tears LOL joking…

But no seriously, it wouldn’t hurt try contacting support to see if anything else that can be done