Can't delete Shares on PR4100, OS5

I am not able to delete shares from my PR4100. I am receiving the following message:
“Unable to delete this network share, Please try again.”

The share is unmounted and is actually empty.

I am logged in as an admin. I restarted the device, but it didn’t help. Could someone please help me?

What you could try is to either System Reset the device shown here: How to Pin Reset and System Only Restore My Cloud OS 5 Devices

Alternatively, and more dangerous: you can log into your device using SSH and delete the share using the Command Line Interface. I will not go into detail how to do this since you should familiarize yourself with this topic before trying to do anything with it.

Hello John, thank you for your reply, I tried the system reset, but the problem remained. I actually wasnt sure why I had to do that. any other suggestion?

Resetting the system settings can resolve a lot of issues.

:anger: Dangerous: You can SSH into the device and use the Command Line Interface to delete the share folder.

Hello John, I have some experiance with Putty, I will try to do as what you suggested, although I don’t know what command should I use, it would be great if you could send me a guide that you trust.

OK, I am writing again as it seems that I have found the cause of the probelm.

TLDR: it seems that I need to put a drive in Slot #1, doing that fixed the issue

I tried to check for a system update because I turned Autoupdate off, and I got this message
“Firmware update failed due to insufficient storage space.”

Looking around I found out that you need to have a drive in Slot#1 to update the system, which was not the case in my current setup, I did that and I was able to run the system update successfully. (no update available)
I then tried to remove these unwanted shares and it also worked.
Hopefully this would help someone else, and thank you JohnRey for trying to help

This post was flagged by the community and is temporarily hidden.