Can't delete files

I’ve looked at all the posts about this and can’t find anything that will help me.  I’m trying to delete a backed up movie, but nothing happens.  It just hangs up and when I try to close out of the deleting process, windows explorer crashes.  I’ve got the error that the file is in use, but nothing is using it.  I’ve tried to log in as the admin and delete it that way and still nothing. 

Same problem with my HD (My Book from 2007) discovered in the diagnostics that there are some bad sectors.

Look for them try to repair. Last instance: format HD

Kept the problem away for some time.

Got the same problem with other data?     

But till last winter the HD was very reliable.

After 4 years of daylie use I bought a new one today. 

1 Like

for some reason, its only this one movie.  i was able to delete another movie with no issue.  running the full test now

What OS? Windows 7 and Vista can be a real pain on permissions, sharing, etc. You may also have to take ownership too.


windows 7 is a pain!  i’ve tried the permissions route as well with no luck.

Some have had luck with Unlocker see if that helps.


i’ve used the unlocker and the file comes up clean.  it just won’t delete

fixed!  the solution to my problem was to reboot the harddrive thru the utilities screen.  :smiley:


Thanks for posting back.