Cant Delete Apple Library Files....?

I have been using my WD Cloud NAS Drive as streaming my Photos Library for my photos. So every time I would load my Photos app on My macbook air it will stream it off my NAS Drive. Was doing this cause the macbook air only has 128gb of space. So I read up on these NAS WD storage devices and learned they are not properly formatted for Apples Photos and iPhoto Libraries so idecided to copy them to another external hard drive that I have and this part gave me trouble. The WD NAS Drive will not let me copy my Photos/iPhoto Libraries over to another external drive, so I found the solution of zipping the Library files then copy them over and it worked. Now, I am trying to delete the Photos/iPhotos Libraries off of my WD NAS Drive since I dont need them anymore and they take up a good amount of space and it will not delete them. The window will come up preparing to delete but wont, I could leave it for hrs and wont do anything.

Any ideas how to delete these apple library files off of my NAS Drive…?

Thanks in advance,

Try to delete them directly accessing your NAS from Finder as opposed to using the iPhotos app. If the process can not be completed then try deleting those files from another computer in your network.

I have tried deleting through the finder and tried from another computer. I even tried from the wd app for the iphone. No luck. Hope wd has a solution for these cause I have a few libraries I need to delete that is taking up alot of space.

You could enable SSH on the MyCloud, log in to the Linux running on it, cd to the location of the library file, and remove it with rm. i.e. use Linux OS commands to delete it.

On a PC, I’d use PuTTY to connect, but I don’t have a Mac, so can only suggest alternative SSH access methods:

can you tell me the prompts to use to get to my folders…?

I’m sorry; I don’t understand what you’re asking for.

To enable SSH on the MyCloud: consult the User Manual.
To connect to the MyCloud via SSH from a Mac: read the article I linked, and do some googling on how to use SSH.
To get to your shares once logged in: cd /shares/<Sharename>. Only you will know what share your data is stored in, and where it is in the file hierarchy in that share. Use further cd commands to change directory to that location.
To delete the offending files once you’re in the right directory: rm <filename>
(Replace <Sharename> and <filename> with the actual names.)

For further information on using Linux, refer to an online Linux primer website.

I’d also suggest you check the access permissions for the share in question (using the Dashboard), to make sure that the user details you have used to connect to the MyCloud has full access, rather than just read access.

ps. I’m just a customer, like you, not someone from WD.

Why do I have to use this method to delete a file…? Why cant I just delete it from the finder itself?


I have no idea. You asked for suggestions to remove the files. I’ve suggested a method; it may or may not work…

Did you check the permissions?

Yes it worked but I’m hoping that wd will fix this issue with a firmware update. How can I check the permissions if this problem comes up again?

You’d better raise a support case with them, then; they don’t generally monitor the forums for problems to fix…

See my earlier reply: use the Dashboard.
It’s worth reading the User Manual; it explains about creating and using Shares, plus lots of other handy stuff.
Linux ls -l is also useful, provided you understand about Linux file permissions; plenty of information to be found with google.