Can't create a folder that starts with a dot

Hello Community,

I have a big problem with my 2 TB myCloud (Firmware: 2.30.193). I’m not able to create a folder on myCloud that starts with a dot (e.g. folder name “.bin”). The same when I try to copy such a folder to my NAS fails (even with robocopy). I also tried to use cmd and the command “mkdir .bin”. No chance, I can’t create the folder!

Please help me on this to resolver this issue. I’m on my end with further ideas what I could try.

Many thanks in advance.

Update: I tried to create a folder with the name “.new folder.”. The folder’s name then will be automatically renamed to “.new folder”. But it doesn’t works with “.bin.”. Why not?!! :frowning:

On Linux (the OS the My Cloud uses), generally using a period/dot at the start of a folder/Share name will cause Linux to treat the folder/Share as a hidden file/folder/Share.

Ok, thanks. But what would be now the solution? I have buyed myCloud as a backup solution. It means I need to transfer my data from my laptop to myCloud, even folders starting with a dot. But this is not working.

I just tried to create a .bin folder in the /tmp folder and it worked on my gen2 My Cloud.

Cannot create a .bin folder on my first gen single bay My Cloud using Windows 10. But can create other folders/files using the period/dot.

Using WinSCP (on Windows 10) I can create a .bin folder.


I didn’t think of using file explorer. I used ssh. But this will work from windows.
new-item w:.bin

PS that is a powershell command.

i created a .bin folder in Windows 7 (cmd/mkdir .bin) and it copied fine onto my My Cloud using Windows explorer

@ Bennor: Same issue to me. I can’t create the folder “.bin” on My Cloud (Gen 1) using Windows 10.
Tried with WinSCP and it works.

@ rac8006: Tried also ssh and it worked too.

Unfortunately all this is only a workaround and I have to do it manually. To perform my backups I’m using robocopy. It means backing up “.bin” folders fails. Very bad and disgusting! :frowning: