Can't copy videos from a MAC

Hi All,

My system:

  • Windows Vista 64 PC

  • iMac 2010 - 21 inches (OS X 10.6.5)

  • MacBook Pro . 13 inches (OS X 10.6.5)

  • Netgear Router

  • WD TV Live Hub connected to my network wirelessly, with a Netgear USB dongle

Both PC and MACs are connected to the router.

I can copy videos from my PC to the TV Live HUB fine, but I can’t do the same with the MAC. With the MAC, I can see the TV Live HUB but when I try to drag files into it, it does not let me do it. I have tried installing MACFuse to see if I could get writing permissions but it didn’t work. I have also tried using NTFSMac, but no go.

Can someone pls help me copying videos from my MAC to the LIVE Hub withouf having to move them to another network drive and go form there?


I suppose you have enabled Windows Sharing in Mac. If sharing is enabled, then try to connect to WDTV:

Finder > Go > Connect to Server…

Select your wdtv

or type:


Connect, and enter following login:

Username (for eg.): Guest

Password: admin

Yes I have

OK. Did you try to connect by using Finder > Go > Connect to server… -method?

Yes I did. I can see the WD Drive with the Mac. When I try to copy a file on it I get the “Copying to…” window with the progress bar, I see the file icon grayed out in the target folder, but when the progress bar  reaches 100 per cent, the file simply has not been copied there, there’s no trace of it.

I know this will sound odd, but I think this problem may be related to another thread, “Permission denied on WD medial live hub share on network - MAC” (

After the progress bar goes away, can you see the file if you connect from your Vista PC?

Macs often (always?) connect to the LiveHub with write-only permission.  If you don’t change any settings, then you can’t see any files on the device - probably even one you just wrote there.  We have a Mac and a PC connected to our LiveHub but when we connected the Mac, all we got was Permission Denied when we tried to do anything.

If you start a terminal session, this command will change the permissions on the mounted LiveHub so that you can read and write files:

        sudo chmod -R 777 /Volumes/WDTVLiveHub

although you will have to do this every time you connect from the Mac.

Hope this helps.

It does work, many thanks!

im having a similar problem but when i try to click and drag a movie into the live hub i get an error saying "the item cant be moved because ‘wdtvlivehub’ cant be modified. I just upgraded to snow leopard and never had this problem when i was runnin 10.4.11. Please help!