Can't copy files from PC to mycloud

This started when I set my PC to share files with my laptop. I think I changed a setting that made it so the mycloud on my network no longer allows me to do anything except read, not writing or deleting. When I drag a file to a mycloud folder, it shows the circle with a line through it meaning I can’t copy.

Anyone know how to fix this?


What setting did you change? How did you set your PC to “share files” with your laptop?

Have you checked the My Cloud Dashboard to ensure the Share is either Public or that the account you use to access the local network Share has full read/write access?

My Cloud OS 5: Access the AdminUI Dashboard

If using Windows one may need to review the Network Sharing section to ensure it’s enabled.

Or review Group Policy Editor to see if they mistakenly changed a setting there that is preventing the saving of files. For example:

Sorry, I have windows 10. Should have mentioned that.

I right clicked on a drive and went to properties, then sharing, and set it up to share. There was a popup asking about the type of network and I think that is where I selected the wrong thing. Maybe something about private or public? I am not sure. It doesn’t pop up now if I try to share another drive on the network. Also, I have verified file and printer sharing is on.

What type of file are you trying to drag and drop? What file do you want to move it to? Are you able to provide an image? See an example image below. If I tried to place the file straight to WDMYCLOUDTWO I get the circle and red line but moving it to a share or share folder works.

My home network is Private. I have all my computers set up to share and they were set up the same way. Two have Windows 11 Pro and one Windows 10 Pro. All three can access my WDMYCLOUDS. Below image is from my desktop, Windows 11 Pro. Click on, tap, or activate image to enlarge it.

Make sure the Network Profile in Windows 10 is configured for Private and not Public.

Also make sure SMB1.0 is enabled since Microsoft typically disables that setting.

My Cloud OS 5, Home & My Passport Wireless: Enable SMB 1.0/CIFS File Sharing Support on Windows 10 & 11

No file will copy. I am copying to a folder that I previously was able to copy to no problem. When I drag a file over the folder, I get the cursor turns into a red circle with a slash through it (not sure what that is called).

I have a feeling I need to change something like this. I have tried this specific setting and it is set to private. I have some time today so I will try and back track, or do what I did to share folders on my pc and laptop and see if I can recreate what I did the first time.

There is no option for this for the mycloud drive, but this is what I did when I set up to share folders with my laptop. I am sure I must have changed some global setting to not allow anything except reading the drive, or other devices in general.

If this was the network “Public” / “Private” thing; you wouldn’t be able to see the MyCloud at all.

I am confused by the problem - →

  • can you copy files from PC to Laptop? Laptop to PC? Either PC to MyCloud?

  • Is the issue pure drag and drop writing to the drive? You can read the files from the mycloud?

  • How are you accessing the drive? Sounds like you are using Windows File Explorer. . .is the mycloud accessed as a “network drive”? Or are you just browsing the folder directly from the “network” section of the Navigation pane?

Note that the “sharing” thing works different from Win Machine to Win Machine than it does from WinMachine to Network drive.