Can't copy files from my pc to my passport

I got the 3 TB My Passport to move my pictures and videos from my pc to my Macbook. I plugged it into my pc and tried to drag & drop and copy/paste the files into the My Passport drive, but the My Passport says there is only 126 mb of free room and only copied one folder. Why is there such little space? There’s nothing else on the My Passport. How can I copy my pictures and videos onto the My Passport? Thanks!

On your PC, open My Computer or File Explorer.

Find the drive, right click, and choose properties.

Post a screenshot.

Ok, that’s a start.

Now go to Disk manager, find the disk in the list. Post a screenshot with that disk visible in the list so we can see how it’s partitioned.

Like this?

Yep… see down there on Disk 1 where is lists a 2794GB partition? That’s unformatted. No idea why E: is a tiny partition.

Right click the E: partition and delete it.
Right click the 2794G partition and delete it, too.

You’ll have a single large unallocated partition. Right click it and format it as NTFS. Should be good to go at that point.

That worked!!! Thank you so much! I never would have figured out how to fix it on my own. Thanks again!

Awesome. You’re welcome!

@TonyPh12345 I don’t know if you are still watching this but I need some help with this too. Same problem but I have differing things.

@EsmeHonora, you don’t seem to have a problem at all.

That looks like your F: disk is a 1TB drive. Are you expecting it to be larger?

I’m only trying to put one folder in right now and it won’t let me. The size is 18.7 GB and my hard drive is completely empty right now but it won’t let put it in there.

Your screen shot seems to indicate you’re trying to paste about 19GB worth of data onto your C: drive, and the C: drive only has 4 GB free.

If you’re trying to copy it to your Passport, the screenshot doesn’t indicate that.

Hey there, I have a similar problem. I recently got a 4 TB My Passport and I want to copy some files from my old 1 TB Passport over as back up. However, I can’t copy them because the message ‘the operation cannot be completed because you don’t have permission to access some of the items’ pops up. I have gone through every folder and set the permissions to read and write for my account and made sure that the setting was also applied to the items contained within each folder. I still can’t copy the files though and I am at a total loss. I can’t for the live of me find the file the message is referring to.