Can't Connect

Good news for everybody!
WD finally got their act together and fixed whatever was causing the major outage.
They will of course never divulge what the problem was!
ICan confirm everything is back as it was before the 9th.

May be back for you. Still no mycloud.com access or WD My Cloud app for Android for me.

Android app throws a “905 error”.

Call them. I think they have the servers back on line. They used the WD My Cloud Android app errors to fix it. I also took the ports out and place it on auto…

As per this morning German time the status page reports the service back online but I’m still unable to connect. Anybody else having the same problem?

For me it works again too

Right now, I’m unable to access. I’m from México.

Device: MyCloud PR1200

It was working for me on the week-end, but now will not connect again. Same old, same old. WD should adopt a new slogan “Losing”, because they will be losing customers. I’m gonna purchase a Synology NAS and run with that instead.

Dear all I’m also getting this message. I can connect using the mobile phone, but on the PC, mycloud isn’t working. I also can connect using directly the IP address and the ADMIN credentials.

To solve Android error, I had to delete the device from the APP and find it again. After that, it was OK. But regarding mycloud.com with Windows 10, no way… this is still not working… :frowning:

Access to the cloud is gone again. For two days everything worked without problems, today it all started again… :disappointed_relieved:
I can’t get into the cloud remotely.

Christos from Greece,

I just bought My Cloud EX2 Ultra 4T a week ago and try to set the system. I lost almost my sleep many nights (I sleep at 1:00 and wake up at 6:00 to go to work :sleeping:) trying to find what I was doing wrong and spending time reading forums how to solve the problem I face. Furthermore english is not my native language so I spend many hours reading and translate in order to find a solution in my problem :hot_face:. I was feeling I am a jerk :crazy_face: and know nothing about NAS. Today by reading this topic I realise that I spend time of my life because as*****es :face_with_symbols_over_mouth: working in a company named WD. I wish I could get in USA and broke their head with the EX2 Ultra :rage:. I have a useless thing on my desk spending energy bought for 270€.

Juicebox is it still working for you. I can not establish connection from my android phone app. nor from chrome.

Network connection error 906, 905 appear
Thanks today is a national holiday in Greece and I can sleep until afternoon.
WD USA rubish

I still don’t have access, what’s going on? is it just me? MyCloud Status shows its working ¬¬

Hey ChristosNtovas, JuanGomez and ChuvizZZ,

It looks like Western Digital broke remote connectivity again. Their files.mycloud.com website and phone apps are both no longer working; again. They only worked for about 1 business week. The browser and phone app both show the device offline. The system shows it is connected and remotely accessible, but we all know that’s not true. Basically, it is the same issue that went on for more than 10 days last time.

Aside from the My Cloud platform… they also messed up their camera surveillance app.

From now on I will be staying away from any Western Digital software dependent WD products. They can make drives, but don’t seem to understand how to make or setup software properly.

Only difference from last time seems to be…

The phone app no longer works locally this time.

My android app have never worked since I bought My EX2 Ultra. I can connect from my cloud login after many tries and typing my username and password 10 times.
Juicebox do you know if I can use the cloud without downloading and uploading my files. I want to work just like the network files I got in my laptop.

Connect a Windows computer to the same local network as the NAS. You will need the device name or IP.

Some ways to get the device name:
When you try to login to files.mycloud.com… you will see your device name there. It’s whatever you set as the name. Another way to see the name is by going to Network in Windows file explorer; see the image bleow. Once you click and open that, while on the same local network, you will see your NAS device name. If you double click the NAS in there, it will open the browser to your devices dashboard.

Once you have your device name or IP:
Open file explorer and type:
\YOUR_IP
or
\YOUR_DEVICE_NAME
The above lines have 2 backslashes in front of the name or IP. The forum strips one of the backslashes… see the second image below for correct backslash placement.
This will display the shares that are on your NAS. Opening the individual shares will require the login; unless they’re public. Once inside a share, you’ll see the files in it and be able to move files on or off the NAS.

This will only work locally.

Untitled

I am back to it not working again after it WAS working for a few days. What is going on?

Same here. Down again.

Its been 20+ days and I still can’t access both of my MyCloud devices online. It takes great incompetence to NOT be able to repair a previously functional software in 20 days… And it takes a great idiocy to tinker with it now in the first place; when half of the world needs to work from home and desperately need online accesibility… I understand there can be some temporary problems but can you imagine Google Drive or iCloud going down for “only” 2 days?? Again, its been not 2, but 20+ days. What kind of r*tards working for WD out there???

Frankly, I never needed Cloud features until now… On a few occassions I’ve used the cloud services, it was more about convinience rather than necessity… Now its necessary and it doesn’t work. If I have to use google drive and dropbox now, then what good is this device for?? For the same amount of money, I could have easily converted my old netbook to a NAS device… It even had a few minutes worth of battery to act as UPS during power outages…

Lesson #1: buy their HDDs if you like but never trust WD for anything else.
Lesson #2: Even a free dropbox account is better than this MyCloud service I’ve indirectly paid by buying this device… Because dropbox at least it works as advertised when it is needed.

2 Likes

Incident Update

Reference #: 200418-002396
Incident Details



Reference #: 200418-002396
Category: Warranty & Replacement
Subject: Can’t connect to My Cloud EX2 Ultra
Product: My Cloud EX2 Ultra

Response by Email Swarupa M
(04/21/2020 08:50 AM)

Dear Christos,

Thank you for contacting Western Digital Service and Support. My name is Swarupa, and I will be happy to assist you today.

I apologize for the inconvenience this has caused you.

As per your email I understand that the drive is malfunctioning or faulty and you are looking for replacement. However, if the device is within return policy, please contact your place of purchase for inquiring a refund.

In order to set up warranty replacement, I would request you to open an online product replacement (RMA): https://westerndigital.secure.force.com/ind/?lang=en_US

Please refer to the links below for more information:

  1. How to get an RMA to replace a defective Product, obtain a Power Supply, or USB cable for a WD Product:
    https://support-en.wd.com/app/answers/detail/a_id/10336

  2. Step-by-Step Instructions to Create an RMA
    https://support-en.wd.com/app/answers/detail/a_id/25679

Note: Western Digital does not cover data recovery under its warranty policy, nor we have any in-house data recovery service. If you need to recover the data on the drive, you must do so before returning the drive to us. We can only provide you the approval to get the data recovered from a certified third party Data Recovery vendor, so that the warranty of the drive will not be void & we will accept your HDD after that.

Additionally, refer mentioned link on “COVID-19 Communication Updates: Western Digital Customer Support”:

I appreciate your patience and understanding. If you have any other issues, kindly reply to this email and we will be happy to assist you further.

Sincerely,
Swarupa
Western Digital Service and Support
http://support.wdc.com

Customer by Service Email CHRISTOS NTOVAS
(04/18/2020 05:52 PM)

  • My Dasboard doesn’t work.

  • Led activity ok. All three led power on.

  • OS Windows 7

  • Home

  • Yes I have tryied to connect from a browser-

1- Power off and back on the gateway, router, modem, and/or switches

2- Power off and back on the Windows or Mac computer being used to setup the device

3- Power off and back on the My Cloud device

4- Follow through the My Cloud process

I have run all this steps and the problem persist.

I also run all other steps you discribe and the problem persist.

I bought a divice that never work. Your product is rubbish.

I want a solution now!!!