Can't connect with wired connection

I’m not sure if i’m right here but I give it a try!

My WD TV Live streaming mediaplayer can’t connect to wired connection.

Wireless works fine but its very slow if I want to transfer a movie to the drive.

I tried to reset, update, different cables and manual.

Edit: The wired connection worked before but just randomly stopt and it couldn’t connect anymore.

My router is Cisco EPC3925

You may want to double check the compatible devices list for the device. If you find that your WD Tv is compatible  with your router and it seems to be a malfuction continue with getting it replaced for a working one.

Knowledge base-

Answer ID 5688,393/session/L3RpbWUvMTMzNDAwMDc2Ny9zaWQvd3lPd1pkVms%3D

it was working before but the next day the Internet was off and it couldn’t connect anymore.

So I guess it should be compatible?


 - A different cable

 - A different port on your router

 - Do the LEDs on both ends light correctly?

I tried different cables, the LEDs light on both ends correctly and I tried all ports.

I even tried to unplug all cable and just connecting it to the media player