Can't connect WDTV SMP to my iMac

Hi everyone! I’ve searched the forums, called WD (they asked me to try with a PC…why is it always like that with Mac!!!), used Google and everything else I know, but I still haven’t found an answer.

My system: iMac 27, Mavericks, WDTV SMP, WiFi; everything uptaded as of yesterday.

The SMP connects to my WiFi perfectly, I can even access internet. What is more, if I connect a USB memory to the SMP, I can access it from my iMac and watch the videos on my computer. However, I can’t do it the other way round.

On my TV, I select videos (same for music & pics), then shared content over network; it detects my computer but then, and this is the issue , it asks me to enter user/password; no matter what i enter (my admin iMac login was the first choice), it keeps on saying wrong username/password. And I’m stuck there.

I’ve read something about Mavericks being SMB2 instead of SMB and that being a possible reason; however, it’s obvious both machines connect (I can acces SMP from iMac), so I guess it might have to do with permissions or something. Besides, I can manage with networks and stuff, but I’m far from expert, so I do feel all this tinkering is far beyond an average user…

Any help appreciated as I’m really frustrated.

Thanks in advance!

I just happened to find a solution. Apparently, SMB doesn’t work properly from Lion upwards. Installing SMBUP has solved the rpoblem. You can find it in  http://eduo.info/apps/smbup

I find it hard to believe that Mac hasn’t fixed it after several yeards, and that WD says nothing about the issue (phone assistance took 30 minutes and was utterly useless, the gut had no idea about Mac OS).

Anyway, hope this help to other L/ML/M OS Mac users.

By the way, this is more patching than fixing the problem, so if anyone can think of a cleaner/better solution, please tell me.

Thanks!

  • Long ago the rapacious monopolist company known as Microsoft devised a networking protocol that locked others out of their networks.

  • Unix & other operating systems implemented SAMBA in order to allow users to connect smb networks regardless of Microsofts desire.

  • MacOS X up to version 10.6.8 being a Unix based operating system also implemented standard SAMBA and all was well.

  • Then in MacOS 10.7 Apple decided to abandon standard SAMBA as implemented everywhere & replace with their own proprietary version that is not backwards compatible with older implentations of smb, only supports smb2. In addition Apples new proprietary version has bugs which they will not fix. In this regard they are now little better than Microsoft.

  • Your WDTV live uses old smb1 therefore it can’t access files shared on Mac’s using MacOS 10.7 or above.

There are three solutions in order of difficulty:

  1. Embrace vendor lockin… Buy an Apple Time Capsule & use that to share files/stream media.

  2. Install a little thrid party app on your Mac which WILL share your media to your WDTV Live eg. Playback, Rivet. I have not tried these but people say good things about them.

  3. Set your Mac up to use the NFS protocol. This is an old Unix protocol that is still present on your Mac & WDTV Live. It will allow you to share/move files back & forth to a local drive connected to your WDTV Live & your Mac (as well as Linux or other Unix machines). A simple HOWTO is here.

  4. Install Linux  or Windows on a spare PC & share the files from it instead. Virtually anything will be able to connect to it. 

Hope this helps…
Chris

“I just happened to find a solution. Apparently, SMB doesn’t work properly from Lion upwards. Installing SMBUP has solved the rpoblem. You can find it in  http://eduo.info/apps/smbup

This is using a sledge hammer to crack a walnut.

May be useful for someone in a business environment but for home users it’s way over the top IMHO.

Thank you for sharing the link…

Chris

fenzof40 wrote:

 

On my TV, I select videos (same for music & pics), then shared content over network; it detects my computer but then, and this is the issue , it asks me to enter user/password; no matter what i enter (my admin iMac login was the first choice), it keeps on saying wrong username/password. And I’m stuck there.

Any help appreciated as I’m really frustrated.

 

Thanks in advance!


 

The first post of the link below explains how to do what you want to do – but it is a Windows based instruction.  There must be a way on a Mac to do what is required in Windows; i.e.Turn OFF password protected sharing.  Otherwise, the instructions are universal.  If nothing else it will tell you how to use passwords if you want to.

 

http://community.wd.com/t5/WD-TV-Live-SMP-Discussions/How-to-resolve-Network-shares-access-problems/m-p/551112#M19218

 

I’m also having the same problem and another thread suggests you have to convert (OSX 10.9 Mavericks) to use NFS and then access Linux Shares on the WDTV LIve instead of Windows shares. I haven’t tried it yet but maybe it will work. Seems like a giant bandaid more than a fix.

http://wdc.custhelp.com/app/answers/detail/a_id/8538

I just figured out a way to do this.

It’s actually really simple and only takes a minute or so. It involves using the NFS functionality on the mac, which can talk to the Linux functionality on the WDTV. I don’t know much about this stuff, but I kept checking help sites and trying different things. Here’s what I did:

First make sure the folder can be shared

  1. On your mac, choose the folder you want to access from your WDTV

  2. Select that folder and and in the menu bar go to File>Get Info

  3. In Get Info make sure the box that says ‘Shared Folder’ is ticked

Use TextEdit to write a single line of code

  1. Open TextEdit

  2. Write the file path to your folder, then a space, then the following text: -alldirs -ro

  3. For example, I’m sharing a folder called ‘Movies’ on my desktop, so the line of code looks like this:

   

    /Users/Simon/Desktop/Movies -alldirs -ro

  1. Save the file (in plain text format) on your desktop as ‘exports’

Remove the .txt file extension from the ‘exports’ file you just created

  1. In the Finder menu bar, go to Finder>Preferences and click the ‘Advanced’ tab

  2. Tick the box that says ‘Show all filename extensions’ (you can change it back later)

  3. The text file you just created will now be called ‘exports.txt’

  4. Select the file name and delete the extension, so it just says ‘exports’

Copy the ‘exports’ file to a mysterious folder called '/etc’

  1. In the Finder menu bar, go to Go>Go to Folder

  2. In the pop up type ‘/etc’ and hit Go

  3. Drag your ‘exports’ text file from the desktop into the ‘etc’ folder. You’ll probably be asked to enter your password.

Change one setting on your WDTV Live to enable Linux Share Support

  1. In your WDTV Live menu screen, go to Settings>Network Settings

  2. Scroll down until you get to ‘Linux Share (NFS) Support’ and make sure it says ‘On’

You’re done

To see your folder go to Select Content Source>Network Share>Linux Shares. It should then show you the IP address of your mac. Just select it and press the green tick and your folder should be right there.

I hope this helps you sort out what was for me a pretty frustrating exercise. All the best.

Thanks Simon78! And if you have more shared folders how you do that?

If you have more folders you have to place them in the /etc/exports file the same way as described in the example.

Off course you have to use the correct name for the folder you add.

I think you have to restart the nfs-service, but I don’t  remember how.

I suppose it is described in the HOWTO mentioned earlier in this post.

Thanks Rudolf19! I would like to know what i use as separator between lines: coma or semicolon or nothing? What is Linux sintax?

Forget about SMB:

  1. Use **Release 2.01.86 (12/10/2013) **update.

  2. Turn on Mac OS share in network settings.

  3. Turn on AFP on Mac.

That’s all.

feinstimmer wrote:

Thanks Rudolf19! I would like to know what i use as separator between lines: coma or semicolon or nothing? What is Linux sintax?

warning, I know nothing about mac’s

but linux export file uses separate lines for multiple shares

so try for a second share putting it on another line

Solved, i did it with emty line between lines of code.

If it were me and I wanted to access more of my files, I’d just go back to the root those files have in common. For example, say I wanted to access other folders on my desktop, I’d share my whole desktop:

/Users/Simon/Desktop -alldirs -ro

If I wanted to access everything in my Documents folder:

/Users/Simon/Documents -alldirs -ro

And if I just wanted to browse all of my stuff:

/Users/Simon -alldirs -ro

I reckon that’s probably easier than creating individual paths to each folder on separate lines.

Cheers

Simon

I’m having the same problem with my Mac running OSX Mavericks 10.9.1. I used to be able to access my Mac files and stream video files fine with my WD TV Live. But since updating to Mavericks, and have just packed away all of my electronics/wifi and set up again after a home renovation, no network shares are working!

I’ve followed Simon78’s instructions, which didn’t work. Then I tried this on the WD site: http://wdc.custhelp.com/app/answers/detail/search/1/a_id/8538/c/130/p/208,393 . I’m quite computer literate so I’m sure I haven’t stuffed anything up in this process.

Everything appears to be ok, but when I get to the final stage and go through to Videos: Select Content Source: Network Shares, every option (Linux and Mac) just searches endlessly. The little arrow just circles forever and never turns up any result, or even a non-result.

Help? =(

I upgraded to Mavericks and found I could no longer connect.

But then I tried the Network Share> Mac Shares option, let it tick over for a few seconds and then my mac popped up, with the actual name of my computer, not just the ip. So I suggest you try this method again.

It works perfectly for me, so someone, somewhere has updated this functionality. As far as I can see, that workaround is no longer required. Which is great. Hope you can get it working.

That’s not working for me. I updated the firmware, went to access Mac shares, and it just spins the little arrow. I have a specific folder shared on my Mac, with both AFP and SMB turned on. Any ideas?

Simon

I got excited when I saw your post.  I have been struggling connecting my iMac running 10.9.4 to my WDTV Live and couldn’t find a solution on line.

I followed your steps till I got to setting up Linux share.  That’s not an option I have under Network Settings. 

Have I missed something?

Or is it that a WDTV SMP is not the same thing as a WDTV Live?

Thanks.

linux shares must first be enabled in settings - network - linux shares - (select on/off)

Thanks KAD79.

I must be missing something.  The only options I get when I go to Network Settings are:

Network setup

Check connection

Share WDTV on your network

Workgroup name

Auto login to network share

Clear login info for network share.

That’s all.