Can't connect to youtube account

Hello,

I just created an account on youtube.
I can connect fine with my PC either using a login like "xxxxx@gmail.com" or just “xxxxx”.

However the WD Tv Live just doesn’t want to connect (using latest firmware 1.07.18)
When I input my credentials, the WD TV Live keeps telling me “incorrect username or password”.
I’ve tried using "xxxx@gmail.com" or “xxxx”, I’ve tried setting my location to “France” (my country), I’ve tried resetting the device (both logically and physically), unplugging it for 10mins, setting language to english etc… to no avail.

I don’t know what to do any more :cry:
Thanks in advance for your help.

Gilles

I just figured this out this past weekend. You need to enable the two-factor authentication on google and create a new password that you can use for shared application such as youtube. Hope that helps…

cheers.

I’m having this same problem.  

I tried your solution wtuser, turning google 2 pass authentication on, and it didn’t work either for me.  Im still getting username or password is incorrect.  However, google did show that I attempted to use the generated app password (last used date was set rather than saying unavailable as it did originally), so obviously my username and pwd were,  in fact, correct.

Ive double checked, and my firmware is up to date.

ETA: Just used a paperclip to do a reset on the box, and tried logging in again with xxx@yyy.ccc (google acct name), and my generated app password, and it gave the usual error.

update:  to (in theory) attempt to clear any cookies on WDTV that may have hung around (despite never actually to all appearances officially logging in), I hit the delete account option.  Nothing came up to indicate anything was deleted, so I did it again just in case.

Then I went to my google account and generated a fresh app password for WDTV, in case the old one had gotten frozen somehow.  I refreshed the page to confirm that last used date said unavailable, indicating it hadn’t been used yet.

Going back to the WDTV, I entered my username xxx@yyy.ccc, and the newly generated password.  I got the usual username or password is incorrect error.

I went back to my google account refreshed the page, and noted that the last used date had been changed from Unavailable to today’s date.  I believe this means as far as google is concerned, I did log into my account  successfully.  

Version is 1.06.16_B

Thank you for your advice wtuser.

I tried what you suggested but, like LazyLeopard, I didn’t have any success.

To Western Digital :

I’m getting so mad trying to make your piece of **bleep** work (I “love” how the WD TV Live just goes back to the home screen in the middle of inputting the password. ** SO MUCH FUN **)

So I’ll save myself the hassle and just stop trying.

Of course, I’ll think twice before buying from you again.

So this was posted months ago… and no response whatsover from WD. Looks like I’m just going to have to return this garbage.