Can't_connect to WDMycloud

#1

Hello

I have so many issues (since 4 days) trying to use my new Mycloud drive that I open a new topic
So after a few days of pain I can finally at least open a shared folder from one computer on my local network (does’t work from other computer on the same network)

If I try to login to mycloud from my “working machine” I get this message

can’t_connect to WDMycloud

Here's what you can do to try and fix the problem:

            Make sure your device is powered on and connected to a network with Internet access. 

Of course because I can copy file using explorer on the same machine
Update the My Cloud firmware. You’ll need to do this from the device dashboard (web interface) under Settings.
Already done
Accept your device’s security certificate.
Note: After you accept the certificate, you might have to refresh this tab to see your files.
If I do this I get this message
This server could not prove that it is device4291117-9166db08.wd2go.com; its security certificate is from device4299604-20ff9e5a.wd2go.com.
This may be caused by a misconfiguration or an attacker intercepting your connection. Learn more.

My goal is to be able to use it “normaly” for Christmas !

Thanks for any help

#2

How are you “logging in” to the My Cloud? Using Windows File Explorer or a web browser or some other program? Are you on the local network or trying to access the My Cloud remotely?

Have you, as suggested in your other thread, taken the time to read through the My Cloud User Manual (http://support.wdc.com/product.aspx?ID=904)?

If you are using Windows 10 and are having trouble using Windows File Explorer to access the My Cloud on the local network take a read through the following thread, it has various suggestions for Windows 10 users. Sometimes Windows 10 itself will block access to the My Cloud and other similar NAS type devices.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576/

Generally for most people the My Cloud IS easy to setup, configure and access. A small number of people will have trouble due to their; computer, local network, or broadband configuration or equipment. It is generally recommended to access the My Cloud on the local network by mapping the My Cloud and using Windows File Explorer or Mac Finder to access the My Cloud to copy files/data back and forth.

http://support.wdc.com/knowledgebase/answer.aspx?ID=2676

http://support.wdc.com/knowledgebase/answer.aspx?ID=2686

Can't connect to MY Cloud
#3

Thanks again Bennor

So as stated in another post “one” of the remaining issue is that from two computer on the same network with both Windows 10 installed , only ONE can open MyCloud drive

I’ve try to change Network configuration as here

Windows 10 Specific Method 1:
Check “Enable Netbios over TCP/IP”. Enable if not enabled. but it didn’t change anything

In the search field type: “network and sharing center” (without quotes) and select Network and Sharing Center.
Select “Change adapter settings”
Right click on the active Network Adapter and select “Properties”.
Select "Internet Protocol Version 4 (TCP/IPv4) from the list, then select the “Properties” button.
Select the “Advanced” button, then select the “WINS” tab.
Select "Enable NetBIOS over TCP/IP. Then select the OK button to close each of the dialog windows.
Reboot the computer.

Unfortunately I’m not in the “most people” set mentioned in your post and this is very frustrating
Windows 10 IS the standard now and it couldn’t be used as an excuse for not working for a widely distributed product

#4

Let’s see: one of your Windows 10 devices works with your MyCloud, and your second Windows 10 device doesn’t.

Where do you think the problem lies? With the MyCloud that is working happily with one of your Windows 10 devices, or with the Windows !0 device that isn’t working with the MyCloud?

Windows 10 has 26% of desktop share, with Windows 7 at 40%.

Windows 10 enforces automatic updates. Those updates have, in the past, been known to cause issues with many devices.

The MyCloud is far from perfect, but, in this case, I’d suggest that it’s some issue of configuration of your PC.