Can't connect to the device through desktop app (WD My Cloud network device from anywhere

I’m trying to connect My Cloud from far away from my house through Desktop App (WD My Cloud network device from anywhere) but it shows the error “Can’t connect to the device”. Further when I try to open through but at the end Java can’t load the share page. It continuous loading loading and loading. In few posts you have shown how to make java setting to medium but when I go to java setting. I’ve only two options “Very High” & “High”. How can I put it into medium when there is no option for it. Hope you guys will help me in this otherwise I have to return this product.

Note: It perfectly works when I came to the same network.

I’m using WD My Cloud 3.0 TB

Windows 7

Browser: google chrome

Hi GameStartNow, welcome to the WD Community. Some of the required ports might be blocked on your router. Try forwarding ports 80 and 443. Check your router manual for more information. Also check if the following link helps. 

How to enable port forwarding on a network router for use with a WD My Cloud, My Book Live, or My Book Live Duo 

1 Like

Thanks alot. It solved the solution regarding desktop app (WD My Cloud network device from anywhere) but my second issue is still pending. How can I change the Java setting to medium because I’ve Java 8 and there are only two option “Very High” & “High”. I had try on both options and try to open in all browsers i.e. google chrome, internet explorer, safari, torch, firefox but it wont work. In internet explorer it at least show the java loading loading and loading but can’t load the share page, in google chrome it hang the page like loading. Hope you guys have also solution for this.

Looking forward to your usual cooperation.



Thanks alot. Finally solved.

GameStartNow wrote:

Thanks alot. Finally solved.

Great! All good then?