Can't connect to MY Cloud

#1

I had no trouble installing my WD My Cloud 4tb and after install it worked just fine.  But now, it doesnt show up when i look in my computer, it shows all the other drives except the My Cloud.  I dont know when in the last few weeks this started but I cant connect to it through my PC, i cant connect remotely via the app on my iPhone, I cant view it in my dashboard online. I tired to connect through the My Cloud program ising my email as well and it still wont connect and I am not sure what to do.  I just noticed it today when i went to transfer some new movies over to it. I verified it has power, and it is plugged into my FIOS modem/router.  Any help would be appreciated.:confounded:

#2

Hello Krispy, Welcome to the WD Community. Is unfortunate that you are unable to access the drive. Have you tried resetting the unit by pressing the reset button in the back of it?

#3

Have you assigned a fixed IP address to your MyCloud through your router? If not, it is likely your router has changed the IP address, hence your problem connecting. Log into your router and reserve an IP address specifically for your MyCloud.

#4

I verified it has power, and it is plugged into my FIOS modem/router.

I suggest looking at your router interface to discover your network. I also have a Verizon Fios router.

  • access 192.168.1.1 (your router’s ‘home page’
  • enter your id a password … if unknown click here
  • after logging in you should see three columns, the middle one provides high level access to your in home network; there you should be able to discover your My Cloud’s connectivity info.
#5

As seen before in other topics, WD MyCloud is apparently unstable, with lots of issues.

Mine is simple, my WD MyCloud is connected, blue, TwonkyServer working, seen in explorer, but FTP and dashboard not working. Tired of trying to make it work, i’ll be returning this bad product of WD and buying a NAS from another brand.

First time WD, will be the last.

3 Likes
#6

Hello Matieu

Unfortunately I come to the same conclusion
I was happy to decide to buy my first NAS a few days ago but it become to be 4 days of nightmare
I’m still in the middle of nowhere with this WDMyCloud

There is another brand with a very nice reputation and apparently a very good UI
Tomorrow is the last day I can switch before Christmas and this would probably be the solution !

1 Like
#7

@OLIVIER_GOOSSENS_BAR, see my reply in your other thread and read the My Cloud User Manual (https://support.wdc.com/product.aspx?ID=904) if you haven’t done so already.

https://community.wd.com/t/cant-connect-to-wdmycloud/189136/2

#8

Thanks for you patience Bennor (Mine is already in another dimension :slight_smile: )

I will resume the situation as it is now !
1 - The WDMycloud is installed (wired) to my Internet Router
2- I have TWO Local computer PC1 and PC2 (both Windows 10) on my private network connected via Wifi
3- I also have a Laptop in my Business office on another Network

From PC 1 Finaly I can

  • Launch Mycloud.com/Setup to see the Dashboard
  • See the Drive AND content from File Explorer
  • See the The Drive and acces two link via the Network folder : Link to Dashboad login Link to Twonky
  • And I can also login via Mycloud.Com

From PC 2 Nothing

  • I can see the drive : thats it
  • NOT possible to see any content
  • NOT Possible to login via Mycloud.Com
  • However from the Network folder I can access the Dashboard and Twonky

So why the hell PC1 and PC2 have different privileges ?

From my Laptop on the external network I can login via Mycloud.Com but I had to install Mycloud local application to be able to access files (normally) without downloading them first !

Ok I will RTFM tonight hoping to find some clue I have missed
I’ll do it because I like challenge but I will never recommend anyone to fall into that mess !

#9

For starters your confusing what the Dashboard actually is. The MyCloud.com/Setup is NOT the actual Dashboard even though it eventually takes the user to the Dashboard. That web address is one way to initially setup the My Cloud. The MyCloud.com site is the internet portal that allows a user to connect remotely to their My Cloud and download/upload files through their web browser to the My Cloud.

Generally one accesses the My Cloud Dashboard from their local network (NOT from a remote location) using one of the following addresses in their web browser:
Windows: http://wdmycloud
Mac: http://wdmycloud.local

That is NOT a My Cloud problem. that is a problem specifically with the configuration of PC #2. Because your using Windows 10 see the following thread for various thing to check in Windows 10.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

In particular do either General Method 1 (recommended) OR General Method 2. Then perform or check PC #2 against Windows 10 Specific Method #1 through #5. Then check your router or the router documentation to see if it supports Master Browser, if so perform the “If router/gateway supports Master Browser” step.

If you continue to have problems with PC #2 review the additional sections Mapped Drive Issues, Problems With Logging Into Private Share, and General Notes That Apply To Windows In General to see if that fixes/resolves the issue(s).

Lastly make sure the computer’s workgroup name (generally “workgroup”) is the same as the workgroup name in the My Cloud Dashboard > Settings > Network > Network Workgroup section. If not change one or the other so they are both identical

#10

Thanks a lot again for your patience Bennor
At the end it pays !

So first of all is seem working better and (I hope as it should be)
So “one” of the last issue was implicitely mentionned by Bennor : The Workgroup
I didn’'t pay to much attention on in because anyway one machine in my Workgroup was able to see the drive !
But in fact the default WorkGroup of WDMycloud is indeed not the same as mine

So setting the right Workgroup fix the “visibility” issue on my PC2 and improve it on my PC1

Now I still have a few comments
1- About the link to the Dashboard : a “good” professional installer should in my opinion propose to create a at least a Desktop Icon
2- About the Workgroup : A good user friendly installer should knows that it may be an issue and suggest during installation to at least insure and Warn that the Workgroup of the WDMyCloud drive hae to match the one use in the local Network

So at the end I’m under the impression that WDMycloud is probably not a "bad " product but certainly not a mature product and different improvement can be made in the installer and the UI to make it more fluent and “understandable”

#11

It did, when I used the setup program, way back in 2014. I then read the Quick Start leaflet in the box, that showed how to access the Dashboard. And I downloaded and read the user manual.

#12

Glad you figured it out. And like was indicated it wasn’t really the My Cloud’s fault rather at some point the PC #2 Network Name/Workgroup Name got changed on your end. Most times the average user doesn’t even know about that setting or need to change it from the default (workgroup) that is set when Windows is installed/configured/setup or they buy a brand new PC.

It should be noted I suggested checking to make sure both the PC and the My Cloud were using the same name (workgroup) in one of your other threads yesterday… :wink:

https://community.wd.com/t/new-to-mycloud/188953/8

#13

It did, when I used the setup program, way back in 2014. I then read the Quick Start leaflet in the box, that showed how to access the Dashboard. And I downloaded and read the user manual.

Not really !

As far as I remember my “install” procedure was only to launch the Mycloud.com/Setup url

And this one does not create or install anything locally I guess !

And this is probably what is missing to get it more Easy !

A real step by step “first launch wizard”

  • to help to understand what’s going on
  • To warn about some highlight (WorkGroup setting for example)
  • To create some shortcut on the desktop or start menu
  • To give a direct explicit link to the manual
#14

My mycloud storage shows an IP address but when I click to connect to it, it tells me that the unit failed to connect. The light in front is now yellow. Can anyone help?