Can't Connect to My Cloud Dashboard

Last night, I tried to play some music - through my Sonos system - which is stored on My Cloud. But, Sonos wouldn’t/couldn’t connect. When I attempted to figure out the problem, I looked up the devices on my home network through my laptop, but My Cloud wasn’t appearing. So, I tried resetting My Cloud (unplugged/replugged) with no success. Then, I did the same with the router. My Cloud was now seen on the network. I can now - partially - access the files on My Cloud. I can view files - photos and music - and open photos through the laptop, but the IP address can’t be accessed when I attempt to play music through Sonos. I thought I’d check the firmware for updates, but I can’t open My Cloud Dashboard. When I run Windows Network Diagnosis, I get the message “Your computer appears to be correctly configured but the device is not responding”. I thought I’d try to ensure the firmware was up to date, in order to eliminate that as the root issue, but how do I do that, if I can’t access the Dashboard?

I don’t think it’s a Sonos problem, because I can stream music from online music services. I just can’t play music from My Cloud. I’m not a computer guru, so my troubleshooting skills are pretty limited. Any help would be appreciated.

It is likely that when you reset your router, it has allocated a different IP address to your mycloud, using DHCP , unless you have taken steps to prevent this (setting an infinite DHCP timeout at the router, or ‘always use this address’, or setting a static IP address using the router).

You said you can see the MyCloud on the network. What IP address has the router given it? Then try to access the Dashboard using the IP address, rather than the name.

You may have to turn off your PC and sonos to get them to figure out the changes to the network, or go through the network configuration process with the sonos again, to tell it where to find the MyCloud, if its IP address has changed.

If you MyCloud was working fine up to this point, I see no need to upgrade the firmware. It was probably just a router crash, and resetting has recovered that, but left your network devices a bit confused. If you want to know how to o firmware upgrades, and generally use the MyCloud, it would be helpful to read the user manual:

If you want to understand and set up the Twonky media server running on the MyCloud, so that it survives issues like this a bit better, you might read this FAQ.

The IP address assigned to MyCloud is, which is as it’s always been. I’ve tried to access it through that IP address, with no success. I’ll try a computer, then a Sonos, reboot and see if that makes a difference. Thanks for your reponse!

Well, this is peculiar. When I look at devices on my network and check the properties of MyCloud, it says the IP address is So why, when I click on the MyCloud Dashboard shortcut, does it try to access When I manually try to connect to, I connect to MyCloud without a problem. But, Sonos is still trying to connect to and I’m not sure what I should be trying to do - try to get Sonos to connect to or get MyCloud back to

Let’s see if I can be more precise in explaining what I see:

When I look at the MyCloud properties under media devices on my network, it gives me IP Address I can only access the Dashboard, using this address, although looking at properties of the Dashboard, I get “”.

When I right-click on “WD MyCloud Public Share” shortcut on my desktop and check properties it gives the URL “file://”. Does this make sense? This is the address that Sonos tries to access, but it won’t connect.

Your router has changed the IP address, using the Dynamic Host Control Protocol.

Your desktop shortcut is out of date; edit it to the new one, or delete it and create a new, correct one.

Your Sonos hasn’t worked out that its media server has moved. Read its manual to find out how to set it to search for, and connect to a media server.

Finally, to prevent this happening again, go to your router’s admin page, find the list of connected devices and their IP addresses, and set the address for the MyCloud to be Static, or infinite lease DHCP, or tick the box that says something like ‘always use this address’.

For a home network, it’s not a bad idea to do this for all devices.

Thanks so much for your help! I have reset the address and now Sonos is able to access My Cloud. It’s late, so I’ll address the static vs DHCP issue later on. Again, many thanks!