Can't connect to my book live after firmware update


I’ve just updated MyBookLive 3TB. In the browser it said that the update is installed, the drive is rebooting, please do not close this window. Well I didn’t close it for 30 minutes, after that I refreshed the browser window and nothing.

None of my PCs see the drive anymore. WD utility on the CD does not find it.

So I’ve connected to the drive directly by WD provided cable. WD utility does not find it. Although I have switched off Windows firewall, antivirus. And I even tried different ethernet cables which are all functional. I also have tried following IPs: (I access WD drive by this IP always)



Basically I tried every IP in provided manual. Even those that were just examples.

I’ve also tried resetting the settings by holding the little button at the back for 4 and more seconds.

It seems the drive is not responding in any way, although it works and network LEDs indicate activity.

I have also checked at:, and it says the device is offline.

ok sorted, sorry for trouble

how you solved this problem??

Have similar unsolved problemm so any help appreciated.

I’m also experiencing the same problem. Would love to know the solution

What did you to fix it as I have the same problem?

Help Similar problem here!

This try this out, maybe it will solve your problem.  Download the WD Link Tool found in

Note: Read the description describing what WD Link Tool does and it might be the answer to your problem.

Best of luck.