Can't connect My Cloud Using ATT Uverse 1Gig Fiber Service

I’m having the same problem. Just switched from Comcast to ATT. I did have a netgear router plugged in to the Comcast router/modem. When I plug my WDcloud directly into the ATT, it doesn’t work. I plug in the netgear router into the ATT, then it works again when I plug it into the Netgear. No one at ATT or WD seems to have a solution. I believe it’s an issue with how the firewall id set up with the ATT router.

I don’t think it is; if there are no lights on the Ethernet connector on the MyCloud, then it has not established any connection with the router. If it was a firewall problem, it would establish an ethernet connection (so the lights would come on), but block traffic.

The fact that it is sorted by sticking a dumb switch in between (which has no intelligence, so looks like a piece of cable, as far as the firewall is concerned) shows that it is a problem of Ethernet link rate autonegotiation between the MyCloud and the router. Each device on its own can establish a connection with other routers or switch (so a switch can successfully act as intermediary between the two), but there’s some problem with the particular combination of MyCloud and AT&T router; thus it’s up to the two companies to work together to sort it out.

Anyone having this problem should report it to WD and AT&T.

As noted earlier, no one has been able to get help from either WD or AT&T. If someone does, please post here. the switch idea works, but it’s pretty unstable.

Had this running for a couple weeks now. It’s working, but I get warnings that the connection is lost or intermittent and warnings that the system has restarted. The switch is a good workaround, but this does not solve the problem of auto negotiation.

Hi! I’ve had the same issue. Drove me CRAZY! You are correct, WD nor ATT was any help. Each pointed the finger at the other.


I was advised to use a switch. I didn’t want to spend any money, so I tried my ‘old’ Linksys router.
It immediately allowed me to see & use MyCloud!! I have not had any issues in the past few weeks, which is when I got it to work.

Attached is the one I am using. It’s over 5 yrs old I believe, so I’m sure there are faster ones? I also do not have all the devices you do…TV, Receivers, etc. Not sure if that is a factor or not.

Hope this helps!
-Bette :grinning:

Note however that using such an old router probably means you are using 10/100 networking and not Gigabit networking for the My Cloud. This means much slower copying/data transfer speeds to and from the My Cloud.

One can buy low cost Gigabit switches from online retailers like Amazon. Here is one for approximately $19 US dollars.

http://www.amazon.com/TP-LINK-TL-SG105-Gigabit-Ethernet-Desktop/dp/B00A128S24/ref=sr_1_1?s=pc&ie=UTF8&qid=1457037974&sr=1-1-spons&keywords=gigabit+switch&psc=1

Thanks. I have no idea what speed I’m getting or if it’s a Gigabit or not.
So far, I haven’t noticed a decrease in speed to MyCloud. I probably should just buy it.

Thanks for the link!!

I am glad I found this thread. Thank you all for saving me hours of support calls. I went out and got a switch from All Tex for $19.00. Hooked it up to my U Verse Router, and hooked up Cloud to the switch and wala. Works just fine.

I have a Linksys wireless network and a Linksys switch. I tried both and get the blue light however, when I try to install the software onto my PC it can’t find the hard drive on the network therefore not allowing me to install the software. I too have Uverse. Any ideas?

First make sure the Linksys switch is connected to the broadband router. Then connect the My Cloud to the Linksys switch. It is a well known problem with ATT Uverse. Most solve it by putting a switch/hub between the My Cloud and the ATT router.

That’s what I did on both routers. I just keep getting the same issue of the software can’t find the router on the network. I tried looking for the IP address on the Uverse router which I found one connected to port 3 where I have the switch connected to but it does nothing when I type in the IP address into my browser… It worked for everyone else, but Im not sure what Im doing wrong. I tried resetting the HD with the 40 second hold, and still nothing on the network.

@ricsteash, are you using more than one “router” on your local network? Using multiple routers on one local network can cause problems if the routers that are connected to the main broadband router are not configured properly. For example, using two or more routers on the local network could introduce multiple IP Address subnets which would cause devices on one IP Address subnet not to be able to communicate (or see) the devices on the second (or additional) IP Address subnets.

Generally if one wants to use a second router as a “hub” or “switch” on their local network they have to first access that second router’s administration page and disable the DHCP server, and assign that second router a static IP Address (and possibly enter DNS/Gateway info as well). Next they have to connect the Ethernet cable from the first/main router to one of the four networking ports on the second router. Do not connect the Ethernet cable to the WAN or Internet port on the second router.

I am having the exact same issue. The WD tech told me this is a common problem with AT&T and to contact them. After several “escalations” and transfers, I was finally put in touch with a “special” tech support that supposedly specializes in connecting 3rd party devices. After 20 minutes on the phone with them, they stated I have a firewall issue that only they can fix and would happily fix it for either a $15/month tech support fee or a one time fee of $49. Thanks to the advice on this thread, i’ll try the work around first. and probably try to reconfigure the firewall myself before i pay them to fix something that shouldn’t be broken.

Ring this expert support back and tell him he’s talking rubbish. Do they give a refund when their firewall fix doesn’t work…?

It’s an autonegotiation problem, not a firewall problem, for the reasons I gave earlier…

Thank you for your posts. I have the same problem reconnecting my Cloud ever since I started with ATT UVerse. I will be buying the switch you recommended and let you know how it works for me.

Ok just found this thread! Maybe someone can help and repeat the process …Basically Uverse and My Cloud don’t talk - correct? Buy an ethernet switch and hook that switch into my uverse box and then hook the my cloud into the switch and it should work? is that what I am reading?

Sorry, I am a little frustrated -I restored a hard drive onto this brand new blue light blinking device that seems to recognize via the internet but when I actually try to get the desktop app, no luck! Little stressed, I just want my files that I paid to restore - Please help!! I am going to call WD tomorrow and maybe go to Best Buy to get said switch for router as well so hopefully this is the correct route as it seems talking to ATT is probably a waste of breath.

Yes that is what you are reading. Connect a switch to the AT&T router’s ethernet port, then connect the My Cloud to the switch.

I too, had the exact same problem–MyCloud 3TB not communicating with my 5268AC AT&T U-verse router. After reading this post, I also purchased the TP-Link switcher referenced here, plugged it in and it instantly worked like a charm!

Mad props to Bennor for the ethernet switch suggestion and cpt_paranoia for recognizing the Autonegotiation issue between WD and AT&T products.

Anybody else having this problem, do yourself a favor and get the ethernet switch. It solved the problem for me immediately.

Same problem here with my WD My Cloud 4 TB, finally had to plug it into an attached Dlink switch.

My NVG599 doesn’t negotiate speed with my My Cloud 4 TB. Had to use a Dlink switch between them.